summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-03-28 00:36:37 +0100
committerGitHub <noreply@github.com>2018-03-28 00:36:37 +0100
commit97fc985fa2928cf1de341a14e9061c973e912e58 (patch)
treef906908c82e7f4435894eceff2e155b07d1e982c /pkgs/top-level
parent418b37a77865fa2f56c5be19da8580278245f17e (diff)
parent1874f09c40bb664470198a8cffa45bab1d31fccc (diff)
downloadnixlib-97fc985fa2928cf1de341a14e9061c973e912e58.tar
nixlib-97fc985fa2928cf1de341a14e9061c973e912e58.tar.gz
nixlib-97fc985fa2928cf1de341a14e9061c973e912e58.tar.bz2
nixlib-97fc985fa2928cf1de341a14e9061c973e912e58.tar.lz
nixlib-97fc985fa2928cf1de341a14e9061c973e912e58.tar.xz
nixlib-97fc985fa2928cf1de341a14e9061c973e912e58.tar.zst
nixlib-97fc985fa2928cf1de341a14e9061c973e912e58.zip
Merge pull request #37936 from vbgl/flow-0.68
flow: 0.66.0 -> 0.68.0
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix2
-rw-r--r--pkgs/top-level/ocaml-packages.nix4
2 files changed, 5 insertions, 1 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index be6957c7a572..8e7bf14f224a 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -7780,7 +7780,7 @@ with pkgs;
   flow = callPackage ../development/tools/analysis/flow {
     inherit (darwin.apple_sdk.frameworks) CoreServices;
     inherit (darwin) cf-private;
-    inherit (ocamlPackages) ocaml findlib camlp4 sedlex ocamlbuild ocaml_lwt
+    inherit (ocamlPackages) ocaml findlib camlp4 sedlex ocamlbuild lwt_ppx
       wtf8 dtoa;
   };
 
diff --git a/pkgs/top-level/ocaml-packages.nix b/pkgs/top-level/ocaml-packages.nix
index 5c2ec39ade7a..7ac8508d889b 100644
--- a/pkgs/top-level/ocaml-packages.nix
+++ b/pkgs/top-level/ocaml-packages.nix
@@ -374,6 +374,10 @@ let
 
     ocaml_lwt = if lib.versionOlder "4.02" ocaml.version then lwt3 else lwt2;
 
+    lwt_ppx = callPackage ../development/ocaml-modules/lwt/ppx.nix {
+      lwt = lwt3;
+    };
+
     lwt_react = callPackage ../development/ocaml-modules/lwt_react {
       lwt = lwt3;
     };