summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2018-02-11 12:37:48 +0100
committerMaximilian Bosch <maximilian@mbosch.me>2018-02-28 12:04:28 +0100
commit97700fe81162818320585ba459d353622566e00a (patch)
treebe642cf40c4e187d6c634cf52de164d5c329f944 /pkgs/top-level
parentf696dda953342e0e48cbbdc62788ded64c1e0ecc (diff)
downloadnixlib-97700fe81162818320585ba459d353622566e00a.tar
nixlib-97700fe81162818320585ba459d353622566e00a.tar.gz
nixlib-97700fe81162818320585ba459d353622566e00a.tar.bz2
nixlib-97700fe81162818320585ba459d353622566e00a.tar.lz
nixlib-97700fe81162818320585ba459d353622566e00a.tar.xz
nixlib-97700fe81162818320585ba459d353622566e00a.tar.zst
nixlib-97700fe81162818320585ba459d353622566e00a.zip
uutils-coreutils: init at 2018-02-09
`uutils-coreutils` is an a cross-platform rewrite of GNU/coreutils based
on Rust. It aims to increase portability and improve Windows support
(see https://github.com/uutils/coreutils#why).

Since the derivation provides the same binaries as `coreutils` does a
`prefix` argument as been added to the function to avoid any conflicts
that can be used like this:

``` nix
self: super:
{
  uutils-coreutils = self.uutils-coreutils.override { prefix = "uutils"; };
}
```

Resolves #28114 /cc @NeQuissimus

-----
Important notice: the patch depends on #34505 which needs to be merged
*FIRST* as it fixes a bug in the `rustc` setup of nixpkgs (see the PR's
discussion and https://github.com/rust-lang/cargo/commit/5c9665f41c6b4d3b99d3b9f8b48a286f5f154692#commitcomment-27271420 for further reference).
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 4235616748c7..5fa4e5278247 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -2035,6 +2035,10 @@ with pkgs;
 
   uudeview = callPackage ../tools/misc/uudeview { };
 
+  uutils-coreutils = callPackage ../tools/misc/uutils-coreutils {
+    inherit (pythonPackages) sphinx;
+  };
+
   zabbix-cli = callPackage ../tools/misc/zabbix-cli { };
 
   ### DEVELOPMENT / EMSCRIPTEN