summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorManuel Reinhardt <reinhardt@syslab.com>2018-03-30 09:30:25 +0200
committerNicolas B. Pierron <nicolas.b.pierron@gmail.com>2018-03-30 12:53:30 +0200
commit91f239e4b0ebd4a7d4f777523ade6551a35af594 (patch)
treeb52e7c78acb42e54fd5e46f52e25b4703d7c1429 /pkgs/top-level
parent7e0ce6f71fb641a271dd1d176cf3ee1342546790 (diff)
downloadnixlib-91f239e4b0ebd4a7d4f777523ade6551a35af594.tar
nixlib-91f239e4b0ebd4a7d4f777523ade6551a35af594.tar.gz
nixlib-91f239e4b0ebd4a7d4f777523ade6551a35af594.tar.bz2
nixlib-91f239e4b0ebd4a7d4f777523ade6551a35af594.tar.lz
nixlib-91f239e4b0ebd4a7d4f777523ade6551a35af594.tar.xz
nixlib-91f239e4b0ebd4a7d4f777523ade6551a35af594.tar.zst
nixlib-91f239e4b0ebd4a7d4f777523ade6551a35af594.zip
bugwarrior: 1.4.0 -> 1.5.1
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix15
1 files changed, 12 insertions, 3 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index cad509f0de84..531bbd521594 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -1850,17 +1850,17 @@ in {
 
   bugwarrior = buildPythonPackage rec {
     name = "bugwarrior-${version}";
-    version = "1.4.0";
+    version = "1.5.1";
 
     src = pkgs.fetchurl {
       url = "mirror://pypi/b/bugwarrior/${name}.tar.gz";
-      sha256 = "1jkz5vzbwspi1jcb3qsgcl619yip77khb696pc3ryk0pdhjhgs5w";
+      sha256 = "0kxknjbw5kchd88i577vlzibg8j60r7zzdhbnragj9wg5s3w60xb";
     };
 
     buildInputs = with self; [ mock unittest2 nose /* jira megaplan */ ];
     propagatedBuildInputs = with self; [
       twiggy requests offtrac bugzilla taskw dateutil pytz keyring six
-      jinja2 pycurl dogpile_cache lockfile click pyxdg
+      jinja2 pycurl dogpile_cache lockfile click pyxdg future15
     ];
 
     # for the moment jira>=0.22 and megaplan>=1.4 are missing for running the test suite.
@@ -7681,6 +7681,15 @@ in {
   };
 
   future = callPackage ../development/python-modules/future { };
+  future15 = self.future.overridePythonAttrs (old: rec {
+    name = "future-${version}";
+    version = "0.15.2";
+    src = fetchPypi {
+      pname = "future";
+      version = "0.15.2";
+      sha256 = "15wvcfzssc68xqnqi1dq4fhd0848hwi9jn42hxyvlqna40zijfrx";
+    };
+  });
 
   futures = buildPythonPackage rec {
     name = "futures-${version}";