summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2018-10-19 11:43:33 -0500
committerMatthew Bauer <mjbauer95@gmail.com>2018-10-29 14:34:10 -0500
commit8db71d9d773956d41778b88d88ead126a0138e67 (patch)
tree1f474caa00b8622f97c025301163cea07ea08e86 /pkgs/top-level
parent2650a1f91ed08049cc6a70051ef238d0fb3dc9e5 (diff)
downloadnixlib-8db71d9d773956d41778b88d88ead126a0138e67.tar
nixlib-8db71d9d773956d41778b88d88ead126a0138e67.tar.gz
nixlib-8db71d9d773956d41778b88d88ead126a0138e67.tar.bz2
nixlib-8db71d9d773956d41778b88d88ead126a0138e67.tar.lz
nixlib-8db71d9d773956d41778b88d88ead126a0138e67.tar.xz
nixlib-8db71d9d773956d41778b88d88ead126a0138e67.tar.zst
nixlib-8db71d9d773956d41778b88d88ead126a0138e67.zip
newlib: init at 3.0.0
Fixes #47533

newlib seems to think it’s a compiler when it’s not. Anyway had to
make host refer to build platform for things to work.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index c6e2205a0bb9..d4749c1f49ba 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -9743,7 +9743,8 @@ with pkgs;
     /**/ if name == "glibc" then targetPackages.glibcCross or glibcCross
     else if name == "bionic" then targetPackages.bionic
     else if name == "uclibc" then targetPackages.uclibcCross
-    else if name == "avrlibc" then targetPackages.avrlibcCross
+    else if name == "avrlibc" then targetPackages.avrlibcCross or avrlibcCross
+    else if name == "newlib" then targetPackages.newlibCross or newlibCross
     else if name == "musl" then targetPackages.muslCross or muslCross
     else if name == "msvcrt" then targetPackages.windows.mingw_w64 or windows.mingw_w64
     else if stdenv.targetPlatform.useiOSPrebuilt then targetPackages.darwin.iosSdkPkgs.libraries
@@ -22836,4 +22837,9 @@ with pkgs;
   };
 
   tsung = callPackage ../applications/networking/tsung {};
+
+  newlib = callPackage ../development/misc/newlib { };
+  newlibCross = callPackage ../development/misc/newlib {
+    stdenv = crossLibcStdenv;
+  };
 }