summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2017-12-31 12:13:18 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2017-12-31 12:13:18 +0100
commit8b905d1cb0751b67a3565c0d8f6e2ae2ba58462d (patch)
tree91a8345b5352e4482775b1c208bb3b181eb83033 /pkgs/top-level
parent1ae541eee42796b924283f88081ccc23d5140674 (diff)
downloadnixlib-8b905d1cb0751b67a3565c0d8f6e2ae2ba58462d.tar
nixlib-8b905d1cb0751b67a3565c0d8f6e2ae2ba58462d.tar.gz
nixlib-8b905d1cb0751b67a3565c0d8f6e2ae2ba58462d.tar.bz2
nixlib-8b905d1cb0751b67a3565c0d8f6e2ae2ba58462d.tar.lz
nixlib-8b905d1cb0751b67a3565c0d8f6e2ae2ba58462d.tar.xz
nixlib-8b905d1cb0751b67a3565c0d8f6e2ae2ba58462d.tar.zst
nixlib-8b905d1cb0751b67a3565c0d8f6e2ae2ba58462d.zip
python.pkgs.biopython: move expression
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix28
1 files changed, 1 insertions, 27 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 925f971d2fa6..26fe809436cf 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -1239,33 +1239,7 @@ in {
     };
   };
 
-  biopython = buildPythonPackage rec {
-    name = "biopython-${version}";
-    version = "1.68";
-
-    src = pkgs.fetchurl {
-      url = "mirror://pypi/b/biopython/${name}.tar.gz";
-      sha256 = "07qc7nz0k77y8hf8s18rscvibvm91zw0kkq7ylrhisf8vp8hkp6i";
-    };
-
-    propagatedBuildInputs = with self; [ numpy ];
-    # Checks try to write to $HOME, which does not work with nix
-    doCheck = false;
-    meta = {
-      description = "Python library for bioinformatics";
-
-      longDescription = ''
-        Biopython is a set of freely available tools for biological computation
-        written in Python by an international team of developers. It is a
-        distributed collaborative effort to develop Python libraries and
-        applications which address the needs of current and future work in
-        bioinformatics.
-      '';
-
-      homepage = http://biopython.org/wiki/Documentation;
-      maintainers = with maintainers; [ luispedro ];
-    };
-  };
+  biopython = callPackage ../development/python-modules/biopython { };
 
   bedup = buildPythonPackage rec {
     version = "0.10.1";