summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFernando J Pando <fernando.pando@stelligent.com>2016-08-30 09:31:20 -0400
committerFrederik Rietdijk <fridh@fridh.nl>2016-09-01 09:53:04 +0200
commit85546fb342d857e82f2d97b2ac17a102a759d403 (patch)
tree5a7f35b14f0163ddf3dfbe332fcdd6e6c106e5ef /pkgs/top-level
parent28b60b19246f841a4ab9a32940c970ce3f91ef9f (diff)
downloadnixlib-85546fb342d857e82f2d97b2ac17a102a759d403.tar
nixlib-85546fb342d857e82f2d97b2ac17a102a759d403.tar.gz
nixlib-85546fb342d857e82f2d97b2ac17a102a759d403.tar.bz2
nixlib-85546fb342d857e82f2d97b2ac17a102a759d403.tar.lz
nixlib-85546fb342d857e82f2d97b2ac17a102a759d403.tar.xz
nixlib-85546fb342d857e82f2d97b2ac17a102a759d403.tar.zst
nixlib-85546fb342d857e82f2d97b2ac17a102a759d403.zip
pythonPackages.txgithub: init at 15.0.0
Tested on Linux
- python 2.7
- python 3.5
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 374b7720b714..5cbc2682a335 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -26562,6 +26562,35 @@ in modules // {
     };
   };
 
+  txgithub = buildPythonPackage rec {
+    name = "${pname}-${version}";
+    pname = "txgithub";
+    version = "15.0.0";
+    src = pkgs.fetchurl {
+      url = "mirror://pypi/t/${pname}/${name}.tar.gz";
+      sha256 = "16gbizy8vkxasxylwzj4p66yw8979nvzxdj6csidgmng7gi2k8nx";
+    };
+    propagatedBuildInputs = with self; [ pyopenssl twisted service-identity ];
+    # fix python3 issues
+    patchPhase = ''
+      sed -i 's/except usage.UsageError, errortext/except usage.UsageError as errortext/' txgithub/scripts/create_token.py
+      sed -i 's/except usage.UsageError, errortext/except usage.UsageError as errortext/' txgithub/scripts/gist.py
+      sed -i 's/print response\[\x27html_url\x27\]/print(response\[\x27html_url\x27\])/' txgithub/scripts/gist.py
+      sed -i '41d' txgithub/scripts/gist.py
+      sed -i '41d' txgithub/scripts/gist.py
+    '';
+
+    # No tests distributed
+    doCheck = false;
+    meta = {
+      description = "GitHub API client implemented using Twisted.";
+      homepage    = "https://github.com/tomprince/txgithub";
+      license     = licenses.mit;
+      maintainers = with maintainers; [ nand0p ];
+      platforms   = platforms.all;
+    };
+  };
+
   txrequests = buildPythonPackage rec {
     name = "${pname}-${version}";
     pname = "txrequests";