summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2016-12-25 11:12:37 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2016-12-25 11:12:53 +0100
commit849f2d9e11541c7c580a03761bc8ef1f2c241c89 (patch)
tree373b568cefaf0c36d0fe9f55031753a7daca0bc1 /pkgs/top-level
parent9f5e022663ebeb11b0e1300dfcc3fbd492c8e72b (diff)
downloadnixlib-849f2d9e11541c7c580a03761bc8ef1f2c241c89.tar
nixlib-849f2d9e11541c7c580a03761bc8ef1f2c241c89.tar.gz
nixlib-849f2d9e11541c7c580a03761bc8ef1f2c241c89.tar.bz2
nixlib-849f2d9e11541c7c580a03761bc8ef1f2c241c89.tar.lz
nixlib-849f2d9e11541c7c580a03761bc8ef1f2c241c89.tar.xz
nixlib-849f2d9e11541c7c580a03761bc8ef1f2c241c89.tar.zst
nixlib-849f2d9e11541c7c580a03761bc8ef1f2c241c89.zip
pythonPackages.html5lib: fix missing buildInputs and tests
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 0105be4d972a..1910e5f8bfa6 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -12514,12 +12514,14 @@ in {
       sha256 = "09j6194f5mlnd5xwbavwvnndwl1x91jw74shxl6hcxjp4fxg3h05";
     };
 
-    buildInputs = with self; [ nose flake8 ];
+    buildInputs = with self; [ flake8 pytest pytest-expect mock ];
     propagatedBuildInputs = with self; [
-      six
+      six webencodings
     ] ++ optionals isPy26 [ ordereddict ];
 
-    checkPhase = "nosetests";
+    checkPhase = ''
+      py.test
+    '';
 
     meta = {
       homepage = https://github.com/html5lib/html5lib-python;