summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorPeter Hoeg <peter@hoeg.com>2018-02-12 22:31:41 +0800
committerGitHub <noreply@github.com>2018-02-12 22:31:41 +0800
commit8016f9b4c90a99d366fe7d3666254c180f3dc834 (patch)
tree7466a012e0baa2ec50c919a0872850c72f069154 /pkgs/top-level
parent8a60770f6b31211ba3d68b812a285fdf619a544f (diff)
parente88284be2a698d9272ce90d2f5ce5b8d4d24465c (diff)
downloadnixlib-8016f9b4c90a99d366fe7d3666254c180f3dc834.tar
nixlib-8016f9b4c90a99d366fe7d3666254c180f3dc834.tar.gz
nixlib-8016f9b4c90a99d366fe7d3666254c180f3dc834.tar.bz2
nixlib-8016f9b4c90a99d366fe7d3666254c180f3dc834.tar.lz
nixlib-8016f9b4c90a99d366fe7d3666254c180f3dc834.tar.xz
nixlib-8016f9b4c90a99d366fe7d3666254c180f3dc834.tar.zst
nixlib-8016f9b4c90a99d366fe7d3666254c180f3dc834.zip
Merge pull request #34611 from peterhoeg/p/descent
descent 1 & 2: use assets from gog.com with the dxx-rebirth project
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix17
1 files changed, 16 insertions, 1 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 391c3017a7c9..e7995ece76a5 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -96,6 +96,11 @@ with pkgs;
     { substitutions = { gnu_config = gnu-config;}; }
     ../build-support/setup-hooks/update-autotools-gnu-config-scripts.sh;
 
+  gogUnpackHook = makeSetupHook {
+    name = "gog-unpack-hook";
+    deps = [ innoextract file-rename ]; }
+    ../build-support/setup-hooks/gog-unpack.sh;
+
   buildEnv = callPackage ../build-support/buildenv { }; # not actually a package
 
   buildFHSUserEnv = callPackage ../build-support/build-fhs-userenv { };
@@ -3236,6 +3241,8 @@ with pkgs;
 
   npm2nix = nodePackages.npm2nix;
 
+  file-rename = callPackage ../tools/filesystems/file-rename { };
+
   kea = callPackage ../tools/networking/kea {
     boost = boost165;
   };
@@ -18384,10 +18391,18 @@ with pkgs;
     physfs = physfs_2;
   };
 
+  # these are here for compatibility
   d1x_rebirth = dxx-rebirth;
-
   d2x_rebirth = dxx-rebirth;
 
+  inherit (callPackages ../games/dxx-rebirth/assets.nix { })
+    descent1-assets
+    descent2-assets;
+
+  inherit (callPackages ../games/dxx-rebirth/full.nix { })
+    d1x-rebirth-full
+    d2x-rebirth-full;
+
   easyrpg-player = callPackage ../games/easyrpg-player { };
 
   eboard = callPackage ../games/eboard { };