summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorJohn Ericson <Ericson2314@Yahoo.com>2017-06-08 12:12:48 -0400
committerJohn Ericson <Ericson2314@Yahoo.com>2017-06-08 14:08:31 -0400
commit7a134572532323900a6661e5f1fea09b6dea3479 (patch)
tree048de4a722e23fb9fbfcd6c83df285b2814e221f /pkgs/top-level
parent35ed21d09636ea85806685c92723a5ebc2d6bb39 (diff)
downloadnixlib-7a134572532323900a6661e5f1fea09b6dea3479.tar
nixlib-7a134572532323900a6661e5f1fea09b6dea3479.tar.gz
nixlib-7a134572532323900a6661e5f1fea09b6dea3479.tar.bz2
nixlib-7a134572532323900a6661e5f1fea09b6dea3479.tar.lz
nixlib-7a134572532323900a6661e5f1fea09b6dea3479.tar.xz
nixlib-7a134572532323900a6661e5f1fea09b6dea3479.tar.zst
nixlib-7a134572532323900a6661e5f1fea09b6dea3479.zip
gcc 7: Remove `cross` arguments and don't use stdenv.is*
These changes were already done for the older GCCs, but 7 slipped
through the cracks.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix4
1 files changed, 0 insertions, 4 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index f8d0d2cc7f90..4abafcac4521 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -5245,10 +5245,6 @@ with pkgs;
     # PGO seems to speed up compilation by gcc by ~10%, see #445 discussion
     profiledCompiler = with stdenv; (!isDarwin && (isi686 || isx86_64));
 
-    # When building `gcc.crossDrv' (a "Canadian cross", with host == target
-    # and host != build), `cross' must be null but the cross-libc must still
-    # be passed.
-    cross = null;
     libcCross = if targetPlatform != buildPlatform then libcCross else null;
 
     isl = if !stdenv.isDarwin then isl_0_17 else null;