summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2014-07-11 06:04:42 +0200
committeraszlig <aszlig@redmoonstudios.org>2014-07-11 06:16:12 +0200
commit79d22ae0151fe198ee34181dfff4183260ffccd2 (patch)
treef80c4c0766f3426c27731e2dd21e7712456c4e1c /pkgs/top-level
parent6863cd091028d5bf4a739c3625537a57fd15bd04 (diff)
downloadnixlib-79d22ae0151fe198ee34181dfff4183260ffccd2.tar
nixlib-79d22ae0151fe198ee34181dfff4183260ffccd2.tar.gz
nixlib-79d22ae0151fe198ee34181dfff4183260ffccd2.tar.bz2
nixlib-79d22ae0151fe198ee34181dfff4183260ffccd2.tar.lz
nixlib-79d22ae0151fe198ee34181dfff4183260ffccd2.tar.xz
nixlib-79d22ae0151fe198ee34181dfff4183260ffccd2.tar.zst
nixlib-79d22ae0151fe198ee34181dfff4183260ffccd2.zip
python-packages: Add package 'sure', v1.2.7.
Unfortunately the upstream version that can be found on PyPI doesn't
include test cases, so we need to fetchgit and wait until tests will be
shipped with a future upstream release.

Reported at gabrielfalcao/sure#61.

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 0f785d235f46..13e9c1ac9e7c 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -7554,6 +7554,30 @@ rec {
     };
   };
 
+
+  sure = buildPythonPackage rec {
+    name = "sure-${version}";
+    version = "1.2.7";
+
+    # Not picking up from PyPI because it doesn't contain tests.
+    src = fetchgit {
+      url = "git://github.com/gabrielfalcao/sure.git";
+      rev = "86ab9faa97aa9c1720c7d090deac2be385ed3d7a";
+      sha256 = "02vffcdgr6vbj80lhl925w7zqy6cqnfvs088i0rbkjs5lxc511b3";
+    };
+
+    buildInputs = [ nose ];
+
+    propagatedBuildInputs = [ six mock ];
+
+    meta = {
+      description = "Utility belt for automated testing";
+      homepage = "http://falcao.it/sure/";
+      license = licenses.gpl3Plus;
+    };
+  };
+
+
   # XXX: ValueError: ZIP does not support timestamps before 1980
   # svneverever =  buildPythonPackage rec {
   #   name = "svneverever-778489a8";