summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2013-02-19 11:49:31 -0500
committerShea Levy <shea@shealevy.com>2013-02-19 11:49:31 -0500
commit79c3f992b4998631b47e26b6c2725af70cb94aaf (patch)
treecb418cbae292fcd5632ea3850dd62148e68afe50 /pkgs/top-level
parent7dfd7a93d43eb391e1177b881cc40ed47706ddca (diff)
downloadnixlib-79c3f992b4998631b47e26b6c2725af70cb94aaf.tar
nixlib-79c3f992b4998631b47e26b6c2725af70cb94aaf.tar.gz
nixlib-79c3f992b4998631b47e26b6c2725af70cb94aaf.tar.bz2
nixlib-79c3f992b4998631b47e26b6c2725af70cb94aaf.tar.lz
nixlib-79c3f992b4998631b47e26b6c2725af70cb94aaf.tar.xz
nixlib-79c3f992b4998631b47e26b6c2725af70cb94aaf.tar.zst
nixlib-79c3f992b4998631b47e26b6c2725af70cb94aaf.zip
makeInitrd: Make the compressor configurable
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 2beabc6a3272..adb4c65a4be7 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -323,9 +323,10 @@ let
     inherit lib;
   };
 
-  makeInitrd = {contents}: import ../build-support/kernel/make-initrd.nix {
-    inherit stdenv perl cpio contents ubootChooser;
-  };
+  makeInitrd = {contents, compressor ? "gzip -9"}:
+    import ../build-support/kernel/make-initrd.nix {
+      inherit stdenv perl cpio contents ubootChooser compressor;
+    };
 
   makeWrapper = makeSetupHook { } ../build-support/setup-hooks/make-wrapper.sh;