summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorMarc Weber <marco-oweber@gmx.de>2010-01-04 07:44:30 +0000
committerMarc Weber <marco-oweber@gmx.de>2010-01-04 07:44:30 +0000
commit78dbd14786a49e7419cf02a0f31c3ccde0a80f29 (patch)
treecffbf3a297012888d78ba4136123e578e4c900a3 /pkgs/top-level
parent568a6e56ebde1559bd2bf159f5c12f2921f5aa02 (diff)
downloadnixlib-78dbd14786a49e7419cf02a0f31c3ccde0a80f29.tar
nixlib-78dbd14786a49e7419cf02a0f31c3ccde0a80f29.tar.gz
nixlib-78dbd14786a49e7419cf02a0f31c3ccde0a80f29.tar.bz2
nixlib-78dbd14786a49e7419cf02a0f31c3ccde0a80f29.tar.lz
nixlib-78dbd14786a49e7419cf02a0f31c3ccde0a80f29.tar.xz
nixlib-78dbd14786a49e7419cf02a0f31c3ccde0a80f29.tar.zst
nixlib-78dbd14786a49e7419cf02a0f31c3ccde0a80f29.zip
provide pkgsi686Linux attr for convinience..
svn path=/nixpkgs/trunk/; revision=19197
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index cbda90ba45aa..c7ebf381dcb0 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -103,6 +103,14 @@ let
   # The package compositions.  Yes, this isn't properly indented.
   pkgsFun = __overrides: with helperFunctions; rec {
 
+  # override system. This is useful to build i686 packages on x86_64-linux
+  forceSystem = system: (import ./all-packages.nix) {
+    inherit system;
+    inherit bootStdenv noSysDirs gccWithCC gccWithProfiling config;
+  };
+
+  # used by wine, firefox with debugging version of Flash, ..
+  pkgsi686Linux = forceSystem "i686-linux";
 
   inherit __overrides;
 
@@ -8557,7 +8565,7 @@ let
   wine =
     if system == "x86_64-linux" then
       # Can't build this in 64-bit; use a 32-bit build instead.
-      (import ./all-packages.nix {system = "i686-linux";}).wine
+      pkgsi686Linux.wine
       # some hackery to make nix-env show this package on x86_64...
       // {system = "x86_64-linux";}
     else