summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2017-02-09 15:11:34 +0100
committerPeter Simons <simons@cryp.to>2017-02-09 15:19:36 +0100
commit768c970c8d339f76947976c31ad2c8723247a8f3 (patch)
tree3f7caccef8f513b186d8d0120f0613dc4fdbfd25 /pkgs/top-level
parentf800a4b1976e90f41e67eb3e7a89c25890ea7b11 (diff)
downloadnixlib-768c970c8d339f76947976c31ad2c8723247a8f3.tar
nixlib-768c970c8d339f76947976c31ad2c8723247a8f3.tar.gz
nixlib-768c970c8d339f76947976c31ad2c8723247a8f3.tar.bz2
nixlib-768c970c8d339f76947976c31ad2c8723247a8f3.tar.lz
nixlib-768c970c8d339f76947976c31ad2c8723247a8f3.tar.xz
nixlib-768c970c8d339f76947976c31ad2c8723247a8f3.tar.zst
nixlib-768c970c8d339f76947976c31ad2c8723247a8f3.zip
python-requests2: use system-wide CA bundle rather than our own
This allows the library to interact gracefully with additional certificates
users might have configured in /etc/ssl/certs/ca-certificates.crt via NixOS.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index bafbb2441afa..f0093ea3cd99 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -22082,7 +22082,6 @@ in {
     };
   };
 
-
   requests = buildPythonPackage rec {
     name = "requests-1.2.3";
     disabled = !pythonOlder "3.4";
@@ -22098,7 +22097,6 @@ in {
     };
   };
 
-
   requests2 = buildPythonPackage rec {
     name = "requests-${version}";
     version = "2.13.0";
@@ -22108,6 +22106,8 @@ in {
       sha256 = "5722cd09762faa01276230270ff16af7acf7c5c45d623868d9ba116f15791ce8";
     };
 
+    patches = [../development/python-modules/requests/0001-requests-certs.py-use-system-wide-cert-bundle-from-N.patch];
+
     nativeBuildInputs = [ self.pytest ];
     # sadly, tests require networking
     doCheck = false;