summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authoradisbladis <adis@blad.is>2017-12-04 09:59:11 +0800
committeradisbladis <adis@blad.is>2017-12-04 09:59:11 +0800
commit74857c9dceb5114bc1dc78d67451c2209b38773e (patch)
tree7b1eddb9c98a8ed316c83f6ecd5d3555acc1a055 /pkgs/top-level
parentb4f4e06982cc6d87f88273edd1149d18cdf49926 (diff)
downloadnixlib-74857c9dceb5114bc1dc78d67451c2209b38773e.tar
nixlib-74857c9dceb5114bc1dc78d67451c2209b38773e.tar.gz
nixlib-74857c9dceb5114bc1dc78d67451c2209b38773e.tar.bz2
nixlib-74857c9dceb5114bc1dc78d67451c2209b38773e.tar.lz
nixlib-74857c9dceb5114bc1dc78d67451c2209b38773e.tar.xz
nixlib-74857c9dceb5114bc1dc78d67451c2209b38773e.tar.zst
nixlib-74857c9dceb5114bc1dc78d67451c2209b38773e.zip
Revert "linux_4_13: Remove, no longer supported."
This reverts commit b39ab30ba7aebb9b148d6edab20c5927982e5ba5.

There are some show stopper issues in the 4.14 kernel that are still
not resolved.

https://github.com/NixOS/nixpkgs/issues/31640
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index fd429f8645da..f549e571abe5 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -12576,6 +12576,22 @@ with pkgs;
       ];
   };
 
+  linux_4_13 = callPackage ../os-specific/linux/kernel/linux-4.13.nix {
+    kernelPatches =
+      [ kernelPatches.bridge_stp_helper
+        kernelPatches.p9_fixes
+        # See pkgs/os-specific/linux/kernel/cpu-cgroup-v2-patches/README.md
+        # when adding a new linux version
+        kernelPatches.cpu-cgroup-v2."4.11"
+        kernelPatches.modinst_arg_list_too_long
+      ]
+      ++ lib.optionals ((platform.kernelArch or null) == "mips")
+      [ kernelPatches.mips_fpureg_emu
+        kernelPatches.mips_fpu_sigill
+        kernelPatches.mips_ext3_n32
+      ];
+  };
+
   linux_4_14 = callPackage ../os-specific/linux/kernel/linux-4.14.nix {
     kernelPatches =
       [ kernelPatches.bridge_stp_helper
@@ -12787,6 +12803,7 @@ with pkgs;
   linuxPackages_rpi = linuxPackagesFor pkgs.linux_rpi;
   linuxPackages_4_4 = recurseIntoAttrs (linuxPackagesFor pkgs.linux_4_4);
   linuxPackages_4_9 = recurseIntoAttrs (linuxPackagesFor pkgs.linux_4_9);
+  linuxPackages_4_13 = recurseIntoAttrs (linuxPackagesFor pkgs.linux_4_13);
   linuxPackages_4_14 = recurseIntoAttrs (linuxPackagesFor pkgs.linux_4_14);
   # Don't forget to update linuxPackages_latest!