summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorTim Steinbach <tim@nequissimus.com>2018-04-01 22:44:23 -0400
committerTim Steinbach <tim@nequissimus.com>2018-04-01 22:44:23 -0400
commit71f28a2ca06f206f982a8eb9b50db4b2b284c550 (patch)
tree5bc6fa6ad849690a7e8dbf08f38b375ac3453ed7 /pkgs/top-level
parent4fdb0a529a4f12034166d2afc2a0cbf9f4faba68 (diff)
downloadnixlib-71f28a2ca06f206f982a8eb9b50db4b2b284c550.tar
nixlib-71f28a2ca06f206f982a8eb9b50db4b2b284c550.tar.gz
nixlib-71f28a2ca06f206f982a8eb9b50db4b2b284c550.tar.bz2
nixlib-71f28a2ca06f206f982a8eb9b50db4b2b284c550.tar.lz
nixlib-71f28a2ca06f206f982a8eb9b50db4b2b284c550.tar.xz
nixlib-71f28a2ca06f206f982a8eb9b50db4b2b284c550.tar.zst
nixlib-71f28a2ca06f206f982a8eb9b50db4b2b284c550.zip
linux: Add 4.16
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix18
1 files changed, 17 insertions, 1 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 0b6b99279f32..09fe7a6851b8 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -13348,6 +13348,21 @@ with pkgs;
       ];
   };
 
+  linux_4_16 = callPackage ../os-specific/linux/kernel/linux-4.16.nix {
+    kernelPatches =
+      [ kernelPatches.bridge_stp_helper
+        # See pkgs/os-specific/linux/kernel/cpu-cgroup-v2-patches/README.md
+        # when adding a new linux version
+        # kernelPatches.cpu-cgroup-v2."4.11"
+        kernelPatches.modinst_arg_list_too_long
+      ]
+      ++ lib.optionals ((platform.kernelArch or null) == "mips")
+      [ kernelPatches.mips_fpureg_emu
+        kernelPatches.mips_fpu_sigill
+        kernelPatches.mips_ext3_n32
+      ];
+  };
+
   linux_testing = callPackage ../os-specific/linux/kernel/linux-testing.nix {
     kernelPatches = [
       kernelPatches.bridge_stp_helper
@@ -13539,7 +13554,7 @@ with pkgs;
   linux = linuxPackages.kernel;
 
   # Update this when adding the newest kernel major version!
-  linuxPackages_latest = linuxPackages_4_15;
+  linuxPackages_latest = linuxPackages_4_16;
   linux_latest = linuxPackages_latest.kernel;
 
   # Build the kernel modules for the some of the kernels.
@@ -13550,6 +13565,7 @@ with pkgs;
   linuxPackages_4_9 = recurseIntoAttrs (linuxPackagesFor pkgs.linux_4_9);
   linuxPackages_4_14 = recurseIntoAttrs (linuxPackagesFor pkgs.linux_4_14);
   linuxPackages_4_15 = recurseIntoAttrs (linuxPackagesFor pkgs.linux_4_15);
+  linuxPackages_4_16 = recurseIntoAttrs (linuxPackagesFor pkgs.linux_4_16);
   # Don't forget to update linuxPackages_latest!
 
   # Intentionally lacks recurseIntoAttrs, as -rc kernels will quite likely break out-of-tree modules and cause failed Hydra builds.