summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2017-12-31 11:25:36 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2017-12-31 11:25:36 +0100
commit718356d6987508658ee2f3224abdc075ec6a0014 (patch)
tree683e6af241e24343cb667f13320f9e946b84497d /pkgs/top-level
parent441839111af66160fb7de993cfe882886db7b77e (diff)
downloadnixlib-718356d6987508658ee2f3224abdc075ec6a0014.tar
nixlib-718356d6987508658ee2f3224abdc075ec6a0014.tar.gz
nixlib-718356d6987508658ee2f3224abdc075ec6a0014.tar.bz2
nixlib-718356d6987508658ee2f3224abdc075ec6a0014.tar.lz
nixlib-718356d6987508658ee2f3224abdc075ec6a0014.tar.xz
nixlib-718356d6987508658ee2f3224abdc075ec6a0014.tar.zst
nixlib-718356d6987508658ee2f3224abdc075ec6a0014.zip
python.pkgs.pytools: fix expression
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix32
1 files changed, 1 insertions, 31 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 4eefa3a7ea8a..05d9e5a4c3e0 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -6789,37 +6789,7 @@ in {
 
   pysrt = callPackage ../development/python-modules/pysrt { };
 
-  pytools = buildPythonPackage rec {
-    name = "pytools-${version}";
-    version = "2017.4";
-
-    src = pkgs.fetchFromGitHub {
-      owner = "inducer";
-      repo = "pytools";
-      rev = "8078e74265bb5a3c9676c698595ab5450cd2bfe7";
-      sha256 = "17q61l79fcxkj5jxg3fnymi652sdjp5s6kpsabgxp22kma9crr28";
-    };
-
-    buildInputs = with self; [
-      decorator
-      appdirs
-      six
-      numpy
-      pytest
-    ];
-
-    checkPhase = ''
-      py.test -k 'not test_persistent_dict'
-    '';
-
-    meta = {
-      homepage = https://github.com/inducer/pytools/;
-      description = "Miscellaneous Python lifesavers.";
-      license = licenses.mit;
-      maintainers = with maintainers; [ artuuge ];
-    };
-
-  };
+  pytools = callPackage ../development/python-modules/pytools { };
 
   pytun = buildPythonPackage rec {
     name = "pytun-${version}";