summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-04-22 12:30:18 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-04-22 12:35:21 -0700
commit6a031c8aa7e31ff0fc66498b7385882fc953e8e6 (patch)
tree70aac3b9e518ea19f8a623acb726330b648ff29d /pkgs/top-level
parentd144b28996b046411471f814c35bd641b903ed51 (diff)
downloadnixlib-6a031c8aa7e31ff0fc66498b7385882fc953e8e6.tar
nixlib-6a031c8aa7e31ff0fc66498b7385882fc953e8e6.tar.gz
nixlib-6a031c8aa7e31ff0fc66498b7385882fc953e8e6.tar.bz2
nixlib-6a031c8aa7e31ff0fc66498b7385882fc953e8e6.tar.lz
nixlib-6a031c8aa7e31ff0fc66498b7385882fc953e8e6.tar.xz
nixlib-6a031c8aa7e31ff0fc66498b7385882fc953e8e6.tar.zst
nixlib-6a031c8aa7e31ff0fc66498b7385882fc953e8e6.zip
snowballstemmer: Add derivation
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index bf058c202b95..e500ccac4eec 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -10940,6 +10940,24 @@ let
     };
   };
 
+  snowballstemmer = buildPythonPackage rec {
+    name = "snowballstemmer-1.2.0";
+
+    src = pkgs.fetchurl {
+      url = "http://pypi.python.org/packages/source/s/snowballstemmer/${name}.tar.gz";
+      md5 = "51f2ef829db8129dd0f2354f0b209970";
+    };
+
+    propagatedBuildInputs = with self; [ PyStemmer ];
+
+    meta = with stdenv.lib; {
+      description = "16 stemmer algorithms (15 + Poerter English stemmer) generated from Snowball algorithms";
+      homepage = http://sigal.saimon.org/en/latest/index.html;
+      license = licenses.bsd3;
+      platforms = platforms.unix;
+    };
+  };
+
   pgpdump = self.buildPythonPackage rec {
     name = "pgpdump-1.5";