summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2012-01-04 17:48:40 +0000
committerPeter Simons <simons@cryp.to>2012-01-04 17:48:40 +0000
commit660701471cf67a6866f75d8a5c4d6c6053e2c0bb (patch)
tree9b5ab95722dafff80816311d6a2372622271df4c /pkgs/top-level
parent2f3cb61b985471987a88f63be64a34caa7705f75 (diff)
downloadnixlib-660701471cf67a6866f75d8a5c4d6c6053e2c0bb.tar
nixlib-660701471cf67a6866f75d8a5c4d6c6053e2c0bb.tar.gz
nixlib-660701471cf67a6866f75d8a5c4d6c6053e2c0bb.tar.bz2
nixlib-660701471cf67a6866f75d8a5c4d6c6053e2c0bb.tar.lz
nixlib-660701471cf67a6866f75d8a5c4d6c6053e2c0bb.tar.xz
nixlib-660701471cf67a6866f75d8a5c4d6c6053e2c0bb.tar.zst
nixlib-660701471cf67a6866f75d8a5c4d6c6053e2c0bb.zip
Dropped obsolete versions of haskell-primitive and haskell-vector.
svn path=/nixpkgs/trunk/; revision=31285
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/haskell-packages.nix12
1 files changed, 2 insertions, 10 deletions
diff --git a/pkgs/top-level/haskell-packages.nix b/pkgs/top-level/haskell-packages.nix
index 2c182e461f4a..b4fdbe463297 100644
--- a/pkgs/top-level/haskell-packages.nix
+++ b/pkgs/top-level/haskell-packages.nix
@@ -1055,9 +1055,7 @@ let result = let callPackage = x : y : modifyPrio (newScope result.final x y);
 
   prettyShow = callPackage ../development/libraries/haskell/pretty-show {};
 
-  primitive_0_3_1 = callPackage ../development/libraries/haskell/primitive/0.3.1.nix {};
-  primitive_0_4_0_1 = callPackage ../development/libraries/haskell/primitive/0.4.0.1.nix {};
-  primitive = self.primitive_0_4_0_1;
+  primitive = callPackage ../development/libraries/haskell/primitive {};
 
   processLeksah = callPackage ../development/libraries/haskell/leksah/process-leksah.nix {};
 
@@ -1341,13 +1339,7 @@ let result = let callPackage = x : y : modifyPrio (newScope result.final x y);
 
   Vec = callPackage ../development/libraries/haskell/Vec {};
 
-  vector_0_7_1 = callPackage ../development/libraries/haskell/vector/0.7.1.nix {
-    primitive = self.primitive_0_3_1;
-  };
-  vector_0_9_1 = callPackage ../development/libraries/haskell/vector/0.9.1.nix {
-    primitive = self.primitive_0_4_0_1;
-  };
-  vector = self.vector_0_9_1;
+  vector = callPackage ../development/libraries/haskell/vector {};
 
   vectorAlgorithms = callPackage ../development/libraries/haskell/vector-algorithms {};