summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorRok Garbas <rok@garbas.si>2013-02-17 15:22:25 -0800
committerRok Garbas <rok@garbas.si>2013-02-17 15:22:25 -0800
commit62542a1556efa6c4cc2ac2f141348407bd251e17 (patch)
treeda29be32788490b14afba3f104c7001de84fba29 /pkgs/top-level
parentf2bff3d088b3c869c1a642e8f226e83c9f3e0972 (diff)
parent77f61dd9878f26dd06fc7232d8d93b9858ded3d8 (diff)
downloadnixlib-62542a1556efa6c4cc2ac2f141348407bd251e17.tar
nixlib-62542a1556efa6c4cc2ac2f141348407bd251e17.tar.gz
nixlib-62542a1556efa6c4cc2ac2f141348407bd251e17.tar.bz2
nixlib-62542a1556efa6c4cc2ac2f141348407bd251e17.tar.lz
nixlib-62542a1556efa6c4cc2ac2f141348407bd251e17.tar.xz
nixlib-62542a1556efa6c4cc2ac2f141348407bd251e17.tar.zst
nixlib-62542a1556efa6c4cc2ac2f141348407bd251e17.zip
Merge pull request #322 from iElectric/deluge
add deluge torrent client and it's dependencies
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix91
1 files changed, 91 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index ff075a5067ca..bf9bea000f8c 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -721,6 +721,60 @@ pythonPackages = python.modules // rec {
     };
   };
 
+  deluge = buildPythonPackage rec {
+    name = "deluge-1.3.5";
+
+    src = fetchurl {
+      url = "http://download.deluge-torrent.org/source/${name}.tar.gz";
+      md5 = "fbf52593a85bfa7c8520834fa9177fba";
+    };
+
+    # TODO: gui, procsettitle
+    buildInputs = [ pkgs.libtorrentRasterbar twisted Mako chardet pyxdg pkgs.pyopenssl ];
+    propagatedBuildInputs = [ pkgs.libtorrentRasterbar twisted Mako chardet pyxdg pkgs.pyopenssl ];
+
+    meta = {
+      homepage = http://deluge-torrent.org;
+      description = "Torrent client";
+      license = "GPLv3";
+      maintainers = [ stdenv.lib.maintainers.iElectric ];
+    };
+  };
+
+  pyxdg = buildPythonPackage rec {
+    name = "pyxdg-0.25";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/p/pyxdg/${name}.tar.gz";
+      md5 = "bedcdb3a0ed85986d40044c87f23477c";
+    };
+
+    # error: invalid command 'test'
+    doCheck = false;
+
+    meta = {
+      homepage = http://freedesktop.org/wiki/Software/pyxdg;
+      description = "Contains implementations of freedesktop.org standards";
+      license = "LGPLv2";
+      maintainers = [ stdenv.lib.maintainers.iElectric ];
+    };
+  };
+
+  chardet = buildPythonPackage rec {
+    name = "chardet-2.1.1";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/c/chardet/${name}.tar.gz";
+      md5 = "295367fd210d20f3febda615a88e1ef0";
+    };
+
+    meta = {
+      homepage = https://github.com/erikrose/chardet;
+      description = "Universal encoding detector";
+      license = "LGPLv2";
+      maintainers = [ stdenv.lib.maintainers.iElectric ];
+    };
+  };
 
   django = buildPythonPackage rec {
     name = "Django-${version}";
@@ -1383,6 +1437,43 @@ pythonPackages = python.modules // rec {
     };
   };
 
+
+  Mako = buildPythonPackage rec {
+    name = "Mako-0.7.3";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/M/Mako/${name}.tar.gz";
+      md5 = "daf7cc50f997533b573f9b40193139a2";
+    };
+
+    buildInputs = [ MarkupSafe nose ];
+    propagatedBuildInputs = [ MarkupSafe ];
+
+    meta = {
+      description = "Super-fast templating language.";
+      homepage = http://www.makotemplates.org;
+      license = "MIT";
+      maintainers = [ stdenv.lib.maintainers.iElectric ];
+    };
+  };
+
+
+  MarkupSafe = buildPythonPackage rec {
+    name = "MarkupSafe-0.15";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/M/MarkupSafe/${name}.tar.gz";
+      md5 = "4e7c4d965fe5e033fa2d7bb7746bb186";
+    };
+
+    meta = {
+      description = "Implements a XML/HTML/XHTML Markup safe string";
+      homepage = http://dev.pocoo.org;
+      license = "BSD";
+      maintainers = [ stdenv.lib.maintainers.iElectric ];
+    };
+  };
+
   manuel = buildPythonPackage rec {
     name = "manuel-${version}";
     version = "1.6.0";