summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorTim Steinbach <tim@nequissimus.com>2018-01-29 11:41:02 -0500
committerTim Steinbach <tim@nequissimus.com>2018-01-29 11:52:50 -0500
commit61043ad4d1425af2d2b5cb3af8b3740fdd90e3ad (patch)
tree1de416c034cf31b2d643f87dca3f0700df1bac75 /pkgs/top-level
parentda26e920789f1d0b63ec9b5af79c611063d4561d (diff)
downloadnixlib-61043ad4d1425af2d2b5cb3af8b3740fdd90e3ad.tar
nixlib-61043ad4d1425af2d2b5cb3af8b3740fdd90e3ad.tar.gz
nixlib-61043ad4d1425af2d2b5cb3af8b3740fdd90e3ad.tar.bz2
nixlib-61043ad4d1425af2d2b5cb3af8b3740fdd90e3ad.tar.lz
nixlib-61043ad4d1425af2d2b5cb3af8b3740fdd90e3ad.tar.xz
nixlib-61043ad4d1425af2d2b5cb3af8b3740fdd90e3ad.tar.zst
nixlib-61043ad4d1425af2d2b5cb3af8b3740fdd90e3ad.zip
linux: Add 4.15
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix18
1 files changed, 16 insertions, 2 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index d89405433a0f..fd5ca5872e36 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -12837,7 +12837,6 @@ with pkgs;
     kernelPatches = with kernelPatches; [
       kernelPatches.bridge_stp_helper
       kernelPatches.modinst_arg_list_too_long
-      kernelPatches.cpu-cgroup-v2."4.11"
       kernelPatches.tag_hardened
     ];
     extraConfig = import ../os-specific/linux/kernel/hardened-config.nix {
@@ -12924,6 +12923,21 @@ with pkgs;
       ];
   };
 
+  linux_4_15 = callPackage ../os-specific/linux/kernel/linux-4.15.nix {
+    kernelPatches =
+      [ kernelPatches.bridge_stp_helper
+        # See pkgs/os-specific/linux/kernel/cpu-cgroup-v2-patches/README.md
+        # when adding a new linux version
+        # kernelPatches.cpu-cgroup-v2."4.11"
+        kernelPatches.modinst_arg_list_too_long
+      ]
+      ++ lib.optionals ((platform.kernelArch or null) == "mips")
+      [ kernelPatches.mips_fpureg_emu
+        kernelPatches.mips_fpu_sigill
+        kernelPatches.mips_ext3_n32
+      ];
+  };
+
   linux_testing = callPackage ../os-specific/linux/kernel/linux-testing.nix {
     kernelPatches = [
       kernelPatches.bridge_stp_helper
@@ -13112,7 +13126,7 @@ with pkgs;
   linux = linuxPackages.kernel;
 
   # Update this when adding the newest kernel major version!
-  linuxPackages_latest = linuxPackages_4_14;
+  linuxPackages_latest = linuxPackages_4_15;
   linux_latest = linuxPackages_latest.kernel;
 
   # Build the kernel modules for the some of the kernels.