summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorRenzo Carbonara <gnuk0001@gmail.com>2017-06-15 18:22:29 +0200
committerRenzo Carbonara <gnuk0001@gmail.com>2017-06-15 19:59:38 +0200
commit5f94d85e5eb33136b1fe3081fe448351347b8d26 (patch)
treef550feec35e95cd67e8460fff733cba3dcac5e5c /pkgs/top-level
parent19f8213a3e49c0ba362c3715d90374e896d16068 (diff)
downloadnixlib-5f94d85e5eb33136b1fe3081fe448351347b8d26.tar
nixlib-5f94d85e5eb33136b1fe3081fe448351347b8d26.tar.gz
nixlib-5f94d85e5eb33136b1fe3081fe448351347b8d26.tar.bz2
nixlib-5f94d85e5eb33136b1fe3081fe448351347b8d26.tar.lz
nixlib-5f94d85e5eb33136b1fe3081fe448351347b8d26.tar.xz
nixlib-5f94d85e5eb33136b1fe3081fe448351347b8d26.tar.zst
nixlib-5f94d85e5eb33136b1fe3081fe448351347b8d26.zip
ghc821: init at 8.2.1-rc2 (a.k.a., 8.2.0.20170507)
The approach taken to add this package was to port over the definitions
currently existing for HEAD, and making the necessesary changes to get
this building.

The Haskell package set associated with this compiler doesn't yet
guarantee that all or most of the packages successfully build with this
new compiler, but that will improve over time after this GHC 8.2.1
is officially released and the ecosystem catches up.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/haskell-packages.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/pkgs/top-level/haskell-packages.nix b/pkgs/top-level/haskell-packages.nix
index 2f21d2a5d74a..099e45f10226 100644
--- a/pkgs/top-level/haskell-packages.nix
+++ b/pkgs/top-level/haskell-packages.nix
@@ -68,6 +68,13 @@ in rec {
       inherit (bootPkgs) hscolour;
       sphinx = pkgs.python27Packages.sphinx;
     };
+    ghc821 = callPackage ../development/compilers/ghc/8.2.1.nix rec {
+      bootPkgs = packages.ghc802;
+      inherit (bootPkgs) hscolour alex happy;
+      inherit buildPlatform targetPlatform;
+      sphinx = pkgs.python3Packages.sphinx;
+      selfPkgs = packages.ghc821;
+    };
     ghcHEAD = callPackage ../development/compilers/ghc/head.nix rec {
       bootPkgs = packages.ghc7103;
       inherit (bootPkgs) alex happy;
@@ -156,6 +163,10 @@ in rec {
       ghc = compiler.ghc802;
       compilerConfig = callPackage ../development/haskell-modules/configuration-ghc-8.0.x.nix { };
     };
+    ghc821 = callPackage ../development/haskell-modules {
+      ghc = compiler.ghc821;
+      compilerConfig = callPackage ../development/haskell-modules/configuration-ghc-8.2.x.nix { };
+    };
     ghcHEAD = callPackage ../development/haskell-modules {
       ghc = compiler.ghcHEAD;
       compilerConfig = callPackage ../development/haskell-modules/configuration-ghc-head.nix { };
@@ -165,6 +176,10 @@ in rec {
       ghc = compiler.ghcHEAD.crossCompiler;
       compilerConfig = callPackage ../development/haskell-modules/configuration-ghc-head.nix { };
     };
+    ghcCross821 = callPackage ../development/haskell-modules {
+      ghc = compiler.ghc821.crossCompiler;
+      compilerConfig = callPackage ../development/haskell-modules/configuration-ghc-8.2.x.nix { };
+    };
     ghcjs = callPackage ../development/haskell-modules {
       ghc = compiler.ghcjs;
       compilerConfig = callPackage ../development/haskell-modules/configuration-ghc-7.10.x.nix { };