summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorcransom <cransom@hubns.net>2016-07-09 13:11:42 -0400
committerFranz Pletz <fpletz@fnordicwalking.de>2016-07-09 19:11:42 +0200
commit5f8a384b65cbe6c256f6b42ed7f35dcac7fca089 (patch)
tree3924442d7279a1f45bd786b3aeaf1aae24227c14 /pkgs/top-level
parenta5ee403f5be449caeb3a5c668df178f04b5d4b5c (diff)
downloadnixlib-5f8a384b65cbe6c256f6b42ed7f35dcac7fca089.tar
nixlib-5f8a384b65cbe6c256f6b42ed7f35dcac7fca089.tar.gz
nixlib-5f8a384b65cbe6c256f6b42ed7f35dcac7fca089.tar.bz2
nixlib-5f8a384b65cbe6c256f6b42ed7f35dcac7fca089.tar.lz
nixlib-5f8a384b65cbe6c256f6b42ed7f35dcac7fca089.tar.xz
nixlib-5f8a384b65cbe6c256f6b42ed7f35dcac7fca089.tar.zst
nixlib-5f8a384b65cbe6c256f6b42ed7f35dcac7fca089.zip
flowlogs_reader: init at 1.0.0 (#16787)
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index f14dbfaea479..1ff7e9b8d5ef 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -6100,6 +6100,29 @@ in modules // {
     propagatedBuildInputs = with self; [ rpkg offtrac urlgrabber fedora_cert ];
   });
 
+  flowlogs_reader = buildPythonPackage rec {
+    name = "flowlogs_reader-1.0.0";
+
+    src = pkgs.fetchurl {
+      url = "mirror://pypi/f/flowlogs_reader/${name}.tar.gz";
+      sha256 = "0158aki6m3pkf98hpd60088qyhrfxkmybdf8hv3qfl8nb61vaiwf";
+    };
+
+    propagatedBuildInputs = with self; [
+      botocore boto3 docutils
+    ];
+    buildInputs = with self; [
+      unittest2 mock
+    ];
+
+    meta = with pkgs.stdenv.lib; {
+      description = "Python library to make retrieving Amazon VPC Flow Logs from CloudWatch Logs a bit easier";
+      homepage = "https://github.com/obsrvbl/flowlogs-reader";
+      maintainers = with maintainers; [ cransom ];
+      license = licenses.asl20;
+    };
+  };
+
   frozendict = buildPythonPackage rec {
     name = "frozendict-0.5";