summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2012-12-07 12:28:58 -0500
committerShea Levy <shea@shealevy.com>2012-12-07 12:28:58 -0500
commit5f8647e7ae71d4739bce444d6f371cf5185116cc (patch)
treed2bc0af9c928dd10562571aac3a115d11740eaf6 /pkgs/top-level
parent1c2439125147cdfb03108a5e2a925063dc64c486 (diff)
parentc47e91117767bbca63d3c3e2ec5d1f12a4faee83 (diff)
downloadnixlib-5f8647e7ae71d4739bce444d6f371cf5185116cc.tar
nixlib-5f8647e7ae71d4739bce444d6f371cf5185116cc.tar.gz
nixlib-5f8647e7ae71d4739bce444d6f371cf5185116cc.tar.bz2
nixlib-5f8647e7ae71d4739bce444d6f371cf5185116cc.tar.lz
nixlib-5f8647e7ae71d4739bce444d6f371cf5185116cc.tar.xz
nixlib-5f8647e7ae71d4739bce444d6f371cf5185116cc.tar.zst
nixlib-5f8647e7ae71d4739bce444d6f371cf5185116cc.zip
Merge branch 'redis' of https://github.com/washort/nixpkgs into upstream
fixes for redis on OSX
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 07c8e3d57015..84ca19b55ddc 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -5471,7 +5471,12 @@ let
 
   radius = callPackage ../servers/radius { };
 
-  redis = callPackage ../servers/nosql/redis { };
+  redis = callPackage ../servers/nosql/redis {
+    stdenv =
+      if stdenv.isDarwin
+      then overrideGCC stdenv gccApple
+      else stdenv;
+  };
 
   redstore = callPackage ../servers/http/redstore { };