summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2012-05-22 15:29:51 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2012-05-22 15:29:51 +0000
commit5c393a469bfb7e7999f898776b375f696d2a76a6 (patch)
tree9861a8fb5059a2baaee977ef41b24a700dd0d9c4 /pkgs/top-level
parent7962af0fe5dc3d8c6a5cde338972d08777e65061 (diff)
downloadnixlib-5c393a469bfb7e7999f898776b375f696d2a76a6.tar
nixlib-5c393a469bfb7e7999f898776b375f696d2a76a6.tar.gz
nixlib-5c393a469bfb7e7999f898776b375f696d2a76a6.tar.bz2
nixlib-5c393a469bfb7e7999f898776b375f696d2a76a6.tar.lz
nixlib-5c393a469bfb7e7999f898776b375f696d2a76a6.tar.xz
nixlib-5c393a469bfb7e7999f898776b375f696d2a76a6.tar.zst
nixlib-5c393a469bfb7e7999f898776b375f696d2a76a6.zip
Adding linux 3.4.
svn path=/nixpkgs/trunk/; revision=34209
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 52c63885f7c6..25eeacd14a08 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -5650,6 +5650,14 @@ let
       ];
   };
 
+  linux_3_4 = makeOverridable (import ../os-specific/linux/kernel/linux-3.4.nix) {
+    inherit fetchurl stdenv perl mktemp module_init_tools ubootChooser;
+    kernelPatches =
+      [ #kernelPatches.fbcondecor_2_6_38
+        kernelPatches.sec_perm_2_6_24
+      ];
+  };
+
   /* Linux kernel modules are inherently tied to a specific kernel.  So
      rather than provide specific instances of those packages for a
      specific kernel, we have a function that builds those packages
@@ -5776,6 +5784,7 @@ let
   linuxPackages_nanonote_jz_2_6_36 = linuxPackagesFor linux_nanonote_jz_2_6_36 pkgs.linuxPackages_nanonote_jz_2_6_36;
   linuxPackages_3_2 = recurseIntoAttrs (linuxPackagesFor pkgs.linux_3_2 pkgs.linuxPackages_3_2);
   linuxPackages_3_3 = recurseIntoAttrs (linuxPackagesFor pkgs.linux_3_3 pkgs.linuxPackages_3_3);
+  linuxPackages_3_4 = recurseIntoAttrs (linuxPackagesFor pkgs.linux_3_4 pkgs.linuxPackages_3_4);
 
   # The current default kernel / kernel modules.
   linux = linuxPackages.kernel;