summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorMartin Bravenboer <martin.bravenboer@logicblox.com>2007-07-04 01:35:29 +0000
committerMartin Bravenboer <martin.bravenboer@logicblox.com>2007-07-04 01:35:29 +0000
commit5983f9183659142a9f59d47cf889e877318b495f (patch)
tree6be73fb74d80de1d8a3d7d3ab9971039c55e1cfb /pkgs/top-level
parent9c542effbefac3bc08edb532042ab0afee2aeadd (diff)
downloadnixlib-5983f9183659142a9f59d47cf889e877318b495f.tar
nixlib-5983f9183659142a9f59d47cf889e877318b495f.tar.gz
nixlib-5983f9183659142a9f59d47cf889e877318b495f.tar.bz2
nixlib-5983f9183659142a9f59d47cf889e877318b495f.tar.lz
nixlib-5983f9183659142a9f59d47cf889e877318b495f.tar.xz
nixlib-5983f9183659142a9f59d47cf889e877318b495f.tar.zst
nixlib-5983f9183659142a9f59d47cf889e877318b495f.zip
A pkgs/development/libraries/aspell/builder.sh
M    pkgs/development/libraries/aspell/default.nix

aspell comes without any dictionaries, so if you actually want to use
it you need to install additional dictionary packages. I've added the
package for English, but obviously more should be added. Dictionaries
are installed in the prefix of aspell.

M    pkgs/top-level/all-packages.nix

aspell dict package for English needs which

added an option enableMPlayer to wrapFirefox to disable the MPlayer
plugin. It's enabled by default.


svn path=/nixpkgs/trunk/; revision=8944
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index c36d7cd37186..027ac21c6c53 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -1223,7 +1223,7 @@ rec {
   };
 
   aspell = import ../development/libraries/aspell {
-    inherit fetchurl stdenv perl;
+    inherit fetchurl stdenv perl which;
   };
 
   audiofile = import ../development/libraries/audiofile {
@@ -3135,12 +3135,11 @@ rec {
 
   wrapFirefox = firefox: import ../applications/networking/browsers/firefox-wrapper {
     inherit stdenv firefox;
-    plugins = [
-      MPlayerPlugin
-    ]
+    plugins = []
     ++ lib.optional (system == "i686-linux") flashplayer
     # RealPlayer is disabled by default for legal reasons.
     ++ lib.optional (system != "i686-linux" && getConfig ["firefox" "enableRealPlayer"] false) RealPlayer
+    ++ lib.optional (getConfig ["firefox" "enableMPlayer"] true) MPlayerPlugin
     ++ lib.optional (supportsJDK && jrePlugin ? mozillaPlugin) jrePlugin;
   };