summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorJude Taylor <me@jude.bio>2015-11-03 13:59:39 -0800
committerJude Taylor <me@jude.bio>2015-11-03 14:00:51 -0800
commit58b862b750dbfe00bc3e935f5ac8857b2fd6a591 (patch)
tree469548cb58942ac9d94e3ff3f4d4df597c66c63e /pkgs/top-level
parent95388b650095705d45b21ead44529c2a92bdb7c8 (diff)
downloadnixlib-58b862b750dbfe00bc3e935f5ac8857b2fd6a591.tar
nixlib-58b862b750dbfe00bc3e935f5ac8857b2fd6a591.tar.gz
nixlib-58b862b750dbfe00bc3e935f5ac8857b2fd6a591.tar.bz2
nixlib-58b862b750dbfe00bc3e935f5ac8857b2fd6a591.tar.lz
nixlib-58b862b750dbfe00bc3e935f5ac8857b2fd6a591.tar.xz
nixlib-58b862b750dbfe00bc3e935f5ac8857b2fd6a591.tar.zst
nixlib-58b862b750dbfe00bc3e935f5ac8857b2fd6a591.zip
darwin purity: pythonPackages.pandas
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index ed71333eb3de..f6ad5d2a8974 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -5677,6 +5677,9 @@ let
 
     propagatedBuildInputs = with self; [ argh pathtools pyyaml ];
 
+    buildInputs = stdenv.lib.optionals stdenv.isDarwin
+      [ pkgs.darwin.apple_sdk.frameworks.CoreServices pkgs.darwin.cf-private ];
+
     doCheck = false;
 
     src = pkgs.fetchurl {
@@ -11836,6 +11839,11 @@ let
       substituteInPlace setup.py \
         --replace "['pandas/src/klib', 'pandas/src']" \
                   "['pandas/src/klib', 'pandas/src', '$cpp_sdk']"
+
+      # disable clipboard tests since pbcopy/pbpaste are not open source
+      substituteInPlace pandas/io/tests/test_clipboard.py \
+        --replace pandas.util.clipboard no_such_module \
+        --replace OSError ImportError
     '';
 
     # The flag `-A 'not network'` will disable tests that use internet.