summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2017-09-05 09:32:04 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2017-09-05 09:32:04 +0200
commit54e502272886f23434306f0aeec60d1802b694be (patch)
tree459ddd5cf8cbfc7f3c9902822135bd29a43d3344 /pkgs/top-level
parente9215bda452984b6caadd74a14763d583f401b6b (diff)
downloadnixlib-54e502272886f23434306f0aeec60d1802b694be.tar
nixlib-54e502272886f23434306f0aeec60d1802b694be.tar.gz
nixlib-54e502272886f23434306f0aeec60d1802b694be.tar.bz2
nixlib-54e502272886f23434306f0aeec60d1802b694be.tar.lz
nixlib-54e502272886f23434306f0aeec60d1802b694be.tar.xz
nixlib-54e502272886f23434306f0aeec60d1802b694be.tar.zst
nixlib-54e502272886f23434306f0aeec60d1802b694be.zip
python.pkgs.bokeh: 0.12.3 -> 0.12.7
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix48
1 files changed, 1 insertions, 47 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 22a1b8e35314..759a9ed22501 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -2106,55 +2106,9 @@ in {
     };
   };
 
-  bokeh = buildPythonPackage rec {
-    name = "bokeh-${version}";
-    version = "0.12.3";
   bkcharts = callPackage ../development/python-modules/bkcharts { };
 
-    src = pkgs.fetchurl {
-      url = "mirror://pypi/b/bokeh/${name}.tar.gz";
-      sha256 = "e138941b62f59bc48bc5b8d249e90c03fed31c1d5abe47ab2ce9e4c83202f73c";
-    };
-
-    disabled = isPyPy;
-
-    # Some test that uses tornado fails
-    doCheck = false;
-
-    buildInputs = with self; [ mock pytest ];
-
-    propagatedBuildInputs = with self; [
-      flask
-      jinja2
-      markupsafe
-      werkzeug
-      itsdangerous
-      dateutil
-      requests
-      six
-      pygments
-      pystache
-      markdown
-      pyyaml
-      pyzmq
-      tornado
-      colorama
-      ]
-      ++ optionals ( !isPy3k ) [ futures ]
-      ++ optionals ( isPy26 ) [ argparse ]
-      ++ optionals ( !isPy3k && !isPyPy ) [ websocket_client ]
-      ++ optionals ( !isPyPy ) [ numpy pandas greenlet ];
-
-    checkPhase = ''
-      ${python.interpreter} -m unittest discover -s bokeh/tests
-    '';
-
-    meta = {
-      description = "Statistical and novel interactive HTML plots for Python";
-      homepage = "http://github.com/bokeh/bokeh";
-      license = licenses.bsd3;
-    };
-  };
+  bokeh = callPackage ../development/python-modules/bokeh { };
 
   boto = buildPythonPackage rec {
     name = "boto-${version}";