summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-03-25 22:19:08 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-03-25 22:19:08 -0700
commit4afecb84e37c0ec00c2f8ca383be146720e03ccf (patch)
tree620d6412d37b2a2b9603ff3629bcbc803dc46736 /pkgs/top-level
parent9d9a393a4bd051df3f7a7d12a9ca695717f55806 (diff)
parentb04f31f801cbdfa39e07a4c7b875d041f2acf60f (diff)
downloadnixlib-4afecb84e37c0ec00c2f8ca383be146720e03ccf.tar
nixlib-4afecb84e37c0ec00c2f8ca383be146720e03ccf.tar.gz
nixlib-4afecb84e37c0ec00c2f8ca383be146720e03ccf.tar.bz2
nixlib-4afecb84e37c0ec00c2f8ca383be146720e03ccf.tar.lz
nixlib-4afecb84e37c0ec00c2f8ca383be146720e03ccf.tar.xz
nixlib-4afecb84e37c0ec00c2f8ca383be146720e03ccf.tar.zst
nixlib-4afecb84e37c0ec00c2f8ca383be146720e03ccf.zip
Merge pull request #6948 from kevinmarsh/master
Add gspread python package
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index c01b3b59ee0f..8281c25e4ea4 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -5139,6 +5139,22 @@ let
     };
   };
 
+  gspread = buildPythonPackage rec {
+    version = "0.2.3";
+    name = "gspread-${version}";
+
+    src = pkgs.fetchurl {
+      url = "https://pypi.python.org/packages/source/g/gspread/${name}.tar.gz";
+      md5 = "5a71e4e3fc509dc1c4d34722f102dec1";
+    };
+
+    meta = {
+      description = "Google Spreadsheets client library";
+      homepage = "https://github.com/burnash/gspread";
+      license = licenses.mit;
+    };
+  };
+
   gyp = buildPythonPackage rec {
     rev = "1977";
     name = "gyp-r${rev}";