summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-04-22 12:31:30 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-04-22 12:35:21 -0700
commit49967a7b3a3ac3d0197a3283e01474db599eb2e6 (patch)
tree06c25d536933567174b0b025d285e324cd03b2e5 /pkgs/top-level
parent6a031c8aa7e31ff0fc66498b7385882fc953e8e6 (diff)
downloadnixlib-49967a7b3a3ac3d0197a3283e01474db599eb2e6.tar
nixlib-49967a7b3a3ac3d0197a3283e01474db599eb2e6.tar.gz
nixlib-49967a7b3a3ac3d0197a3283e01474db599eb2e6.tar.bz2
nixlib-49967a7b3a3ac3d0197a3283e01474db599eb2e6.tar.lz
nixlib-49967a7b3a3ac3d0197a3283e01474db599eb2e6.tar.xz
nixlib-49967a7b3a3ac3d0197a3283e01474db599eb2e6.tar.zst
nixlib-49967a7b3a3ac3d0197a3283e01474db599eb2e6.zip
sphinx: 1.2.3 -> 1.3.1
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix33
1 files changed, 27 insertions, 6 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index e500ccac4eec..ea0035b47922 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -11399,21 +11399,42 @@ let
 
 
   sphinx = buildPythonPackage (rec {
-    name = "Sphinx-1.2.3";
+    name = "Sphinx-1.3.1";
 
     src = pkgs.fetchurl {
       url = "http://pypi.python.org/packages/source/S/Sphinx/${name}.tar.gz";
-      md5 = "a98c93124035b4cd7183604aec656cb3";
+      md5 = "8786a194acf9673464c5455b11fd4332";
     };
 
-    propagatedBuildInputs = with self; [docutils jinja2 pygments];
+    propagatedBuildInputs = with self; [ docutils jinja2 pygments sphinx_rtd_theme alabaster Babel snowballstemmer  six ];
 
-    meta = {
+    meta = with stdenv.lib; {
       description = "Sphinx is a tool that makes it easy to create intelligent and beautiful documentation for Python projects.";
-
       homepage = http://sphinx.pocoo.org/;
+      license = licenses.bsd3;
+      platforms = platforms.unix;
+    };
+  });
 
-      license = "BSD";
+
+  sphinx_rtd_theme = buildPythonPackage (rec {
+    name = "sphinx_rtd_theme-0.1.7";
+
+    src = pkgs.fetchurl {
+      url = "http://pypi.python.org/packages/source/s/sphinx_rtd_theme/${name}.tar.gz";
+      md5 = "3ffe014445195705968d899c38b305fd";
+    };
+
+    postPatch = ''
+      rm requirements.txt
+      touch requirements.txt
+    '';
+
+    meta = with stdenv.lib; {
+      description = "ReadTheDocs.org theme for Sphinx, 2013 version";
+      homepage = https://github.com/snide/sphinx_rtd_theme/;
+      license = licenses.bsd3;
+      platforms = platforms.unix;
     };
   });