summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2012-08-27 11:26:46 -0400
committerShea Levy <shea@shealevy.com>2012-08-27 11:26:46 -0400
commit488f46c19c4182ac1f6206c0803eb848714a676f (patch)
tree00a03292519b37e9d55b1c2bccb9de990bbd3efa /pkgs/top-level
parent289d7a5cfa7518a730260e7a92a0507398acd432 (diff)
parent016b665402807c7c4f54622cce75fd94c13aa55e (diff)
downloadnixlib-488f46c19c4182ac1f6206c0803eb848714a676f.tar
nixlib-488f46c19c4182ac1f6206c0803eb848714a676f.tar.gz
nixlib-488f46c19c4182ac1f6206c0803eb848714a676f.tar.bz2
nixlib-488f46c19c4182ac1f6206c0803eb848714a676f.tar.lz
nixlib-488f46c19c4182ac1f6206c0803eb848714a676f.tar.xz
nixlib-488f46c19c4182ac1f6206c0803eb848714a676f.tar.zst
nixlib-488f46c19c4182ac1f6206c0803eb848714a676f.zip
Merge branch 'openjdk-default' of github.com:shlevy/nixpkgs
With this change, java packages will build with openjdk by default. The
primary driver for this is legal: The build farm is not allowed to
distribute the proprietary Oracle jdk6, and so it is not allowed to
distribute any packages that depend on it. In my view, this is a purely
beneficial change: from the perspective of the build farm, packages will
go from undistributable due to licensing to either distributable or
undistributable due to failed build (if the package doesn't build
properly with openjdk), and from the perspective of the end user it is
very easy to override the jdk on a package-by-package basis or for all
of nixpkgs in the nixpkgs configuration.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 31cbe85624da..f01ae4a9c0ba 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -2359,8 +2359,12 @@ let
     jreOnly = true;
   };
 
-  jdk = if stdenv.isDarwin then openjdk else jdkdistro true false;
-  jre = jdkdistro false false;
+  jdk = if (stdenv.isDarwin || stdenv.system == "i686-linux" || stdenv.system == "x86_64-linux")
+    then openjdk
+    else jdkdistro true false;
+  jre = if (stdenv.system == "i686-linux" || stdenv.system == "x86_64-linux")
+    then openjre
+    else jdkdistro false false;
 
   jrePlugin = lowPrio (jdkdistro false true);