summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorArseniy Seroka <jagajaga@users.noreply.github.com>2015-02-18 22:31:26 +0300
committerArseniy Seroka <jagajaga@users.noreply.github.com>2015-02-18 22:31:26 +0300
commit4880416b31cf269e794e45a94b58948310b8958c (patch)
treeeb085e487644a6c68337599bfb3083ae6f872292 /pkgs/top-level
parent5968adcaacbe66e6eec0da36542fb893023842da (diff)
parent7e4e671c54038eca7e86b09ef94f10651aad85ce (diff)
downloadnixlib-4880416b31cf269e794e45a94b58948310b8958c.tar
nixlib-4880416b31cf269e794e45a94b58948310b8958c.tar.gz
nixlib-4880416b31cf269e794e45a94b58948310b8958c.tar.bz2
nixlib-4880416b31cf269e794e45a94b58948310b8958c.tar.lz
nixlib-4880416b31cf269e794e45a94b58948310b8958c.tar.xz
nixlib-4880416b31cf269e794e45a94b58948310b8958c.tar.zst
nixlib-4880416b31cf269e794e45a94b58948310b8958c.zip
Merge pull request #6439 from mvcisback/uncertainties
Add uncertainties python package
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index b49048d226f0..10e56be1f284 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -13143,6 +13143,24 @@ let
     };
   };
 
+  uncertainties = buildPythonPackage rec {
+    name = "uncertainties-2.4.6.1";
+
+    src = pkgs.fetchurl {
+       url = "https://github.com/lebigot/uncertainties/archive/2.4.6.1.tar.gz";
+       sha256 = "993ad1a380185ff9548510401ed89fe96cf1f18ca48b44657356c8dcd3ad5032";
+    };
+
+    buildInputs = with self; [ nose numpy ];
+   
+    meta = {
+      homepage = "http://pythonhosted.org/uncertainties/";
+      description = "Transparent calculations with uncertainties on the quantities involved (aka error propagation)";
+      license = licenses.bsd3;
+    };
+  };
+
+
 # python2.7 specific packages
 } // optionalAttrs isPy27 (
   with self;