summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorPeter Hoeg <peter@hoeg.com>2017-11-02 16:35:40 +0800
committerOrivej Desh <orivej@gmx.fr>2017-11-05 18:43:30 +0000
commit43934459fa82b99abab5565fac537922aecf08ce (patch)
treefb3868f8631d03ba8d72fe692902047b2cfe70ed /pkgs/top-level
parentce1b0c05a52f70fbf03c277018384c9bac3fdf56 (diff)
downloadnixlib-43934459fa82b99abab5565fac537922aecf08ce.tar
nixlib-43934459fa82b99abab5565fac537922aecf08ce.tar.gz
nixlib-43934459fa82b99abab5565fac537922aecf08ce.tar.bz2
nixlib-43934459fa82b99abab5565fac537922aecf08ce.tar.lz
nixlib-43934459fa82b99abab5565fac537922aecf08ce.tar.xz
nixlib-43934459fa82b99abab5565fac537922aecf08ce.tar.zst
nixlib-43934459fa82b99abab5565fac537922aecf08ce.zip
pythonPackages.pygit2: 0.25.1 -> 0.26.0
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix40
1 files changed, 1 insertions, 39 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index e4600cf162a5..98470de6b52e 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -15674,45 +15674,7 @@ in {
     };
   };
 
-  pygit2 = buildPythonPackage rec {
-    name = "pygit2-0.25.1";
-
-    src = pkgs.fetchurl {
-      url = "mirror://pypi/p/pygit2/${name}.tar.gz";
-      sha256 = "0sja3g9mqwp5bnhdc313b2gc4z3p70nn6zzf2h8j581g0lrn0sg8";
-    };
-
-    # Fixes a bug which can cause test failed when cffi==1.10
-    prePatch = let
-      cffiVersionPatch = pkgs.fetchurl {
-        url = "https://github.com/libgit2/pygit2/commit/b88dc868423af2f760f649960112efd0e37e5335.patch";
-        sha256 = "14cfrz56y2dnwlxrrss9pjhxfnyyg5856gbabzjzyx674k0qcid4";
-      };
-    in ''
-      # we need to delete part of the patch because the missing .travis.yml causes problem
-      sed -e '1,36d' ${cffiVersionPatch} | patch -p1
-    '';
-
-    preConfigure = ( if stdenv.isDarwin then ''
-      export DYLD_LIBRARY_PATH="${pkgs.libgit2}/lib"
-    '' else "" );
-
-    propagatedBuildInputs = with self; [ pkgs.libgit2 six ] ++ optionals (!isPyPy) [ cffi ];
-
-    preCheck = ''
-      # disable tests that require networking
-      rm test/test_repository.py
-      rm test/test_credentials.py
-      rm test/test_submodule.py
-    '';
-
-    meta = {
-      homepage = https://pypi.python.org/pypi/pygit2;
-      description = "A set of Python bindings to the libgit2 shared library";
-      license = licenses.gpl2;
-      platforms = platforms.all;
-    };
-  };
+  pygit2 = callPackage ../development/python-modules/pygit2 { };
 
   Babel = buildPythonPackage (rec {
     name = "Babel-2.3.4";