summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2017-09-05 09:45:55 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2017-09-05 09:45:55 +0200
commit413b54bcef65a31bc2dda01b3e084682fad78c4a (patch)
treee7bdf6d7c49b3630d5bb990d48bcc359bae8c1a0 /pkgs/top-level
parent54e502272886f23434306f0aeec60d1802b694be (diff)
downloadnixlib-413b54bcef65a31bc2dda01b3e084682fad78c4a.tar
nixlib-413b54bcef65a31bc2dda01b3e084682fad78c4a.tar.gz
nixlib-413b54bcef65a31bc2dda01b3e084682fad78c4a.tar.bz2
nixlib-413b54bcef65a31bc2dda01b3e084682fad78c4a.tar.lz
nixlib-413b54bcef65a31bc2dda01b3e084682fad78c4a.tar.xz
nixlib-413b54bcef65a31bc2dda01b3e084682fad78c4a.tar.zst
nixlib-413b54bcef65a31bc2dda01b3e084682fad78c4a.zip
python.pkgs.prompt_toolkit: 1.0.14 -> 1.0.15
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix37
1 files changed, 5 insertions, 32 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 759a9ed22501..dca008eee604 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -16457,41 +16457,14 @@ in {
   };
 
 
-  prompt_toolkit = buildPythonPackage rec {
-    name = "prompt_toolkit-${version}";
-    version = "1.0.14";
+  prompt_toolkit = callPackage ../development/python-modules/prompt_toolkit { };
 
-    src = pkgs.fetchurl {
-      sha256 = "cc66413b1b4b17021675d9f2d15d57e640b06ddfd99bb724c73484126d22622f";
-      url = "mirror://pypi/p/prompt_toolkit/${name}.tar.gz";
-    };
-    checkPhase = ''
-      rm prompt_toolkit/win32_types.py
-      py.test -k 'not test_pathcompleter_can_expanduser'
-    '';
-
-    buildInputs = with self; [ pytest ];
-    propagatedBuildInputs = with self; [ docopt six wcwidth pygments ];
-
-    meta = {
-      description = "Python library for building powerful interactive command lines";
-      longDescription = ''
-        prompt_toolkit could be a replacement for readline, but it can be
-        much more than that. It is cross-platform, everything that you build
-        with it should run fine on both Unix and Windows systems. Also ships
-        with a nice interactive Python shell (called ptpython) built on top.
-      '';
-      homepage = https://github.com/jonathanslenders/python-prompt-toolkit;
-      license = licenses.bsd3;
-      maintainers = with maintainers; [ nckx ];
-    };
-  };
-  prompt_toolkit_52 = self.prompt_toolkit.override(self: rec {
-    name = "prompt_toolkit-${version}";
+  prompt_toolkit_52 = self.prompt_toolkit.overridePythonAttrs(oldAttrs: rec {
+    name = "${oldAttrs.pname}-${version}";
     version = "0.52";
-    src = pkgs.fetchurl {
+    src = oldAttrs.src.override {
+      inherit version;
       sha256 = "00h9ldqmb33nhg2kpks7paldf3n3023ipp124alwp96yz16s7f1m";
-      url = "mirror://pypi/p/prompt_toolkit/${name}.tar.gz";
     };
 
     # No tests included in archive