summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorYury G. Kudryashov <urkud.urkud@gmail.com>2007-06-28 09:53:12 +0000
committerYury G. Kudryashov <urkud.urkud@gmail.com>2007-06-28 09:53:12 +0000
commit40657fbece8c96f3049b1f826dee9e5ef230f147 (patch)
treeca1873dad7744c18af22685a543d4ac50c2b7424 /pkgs/top-level
parentd80093f2ff46bf86ea2c2346c0fc2cf722509f95 (diff)
downloadnixlib-40657fbece8c96f3049b1f826dee9e5ef230f147.tar
nixlib-40657fbece8c96f3049b1f826dee9e5ef230f147.tar.gz
nixlib-40657fbece8c96f3049b1f826dee9e5ef230f147.tar.bz2
nixlib-40657fbece8c96f3049b1f826dee9e5ef230f147.tar.lz
nixlib-40657fbece8c96f3049b1f826dee9e5ef230f147.tar.xz
nixlib-40657fbece8c96f3049b1f826dee9e5ef230f147.tar.zst
nixlib-40657fbece8c96f3049b1f826dee9e5ef230f147.zip
* ncurses: added symlinks for bynary packages linked against libncurses. Tested
           with ghc. I will add 'unicode' option next check in (for cygwin).
* pidgin:  Got rid of builder.sh, added ncurses to the dependencies, so it builds
           finch.
* xorg:    Added glproto and mesaHeaders to xf86videosis dependencies. Now it
           compiles.
* pwgen:   Added.
* device-mapper: Version bump. Added 'static' option for use in initrd.
* lvm2:          Version bump. Added 'static' option for use in initrd.

svn path=/nixpkgs/trunk/; revision=8923
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix17
1 files changed, 16 insertions, 1 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 3476cb8838ee..d2a9e466f6fe 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -494,6 +494,10 @@ rec {
     inherit (xlibs) libX11;
   };
 
+  pwgen = import ../tools/security/pwgen {
+    inherit stdenv fetchurl;
+  };
+
   qtparted = import ../tools/misc/qtparted {
     inherit fetchurl stdenv e2fsprogs ncurses readline parted zlib qt3;
     inherit (xlibs) libX11 libXext;
@@ -2232,6 +2236,11 @@ rec {
     inherit fetchurl stdenv;
   };
 
+  devicemapperStatic = lowPrio (appendToName "static" (import ../os-specific/linux/device-mapper {
+    inherit fetchurl stdenv;
+    static = true;
+  }));
+
   dietlibc = import ../os-specific/linux/dietlibc {
     inherit fetchurl glibc;
     # Dietlibc 0.30 doesn't compile on PPC with GCC 4.1, bus GCC 3.4 works.
@@ -2435,6 +2444,12 @@ rec {
     inherit fetchurl stdenv devicemapper;
   };
 
+  lvm2Static = lowPrio (appendToName "static" (import ../os-specific/linux/lvm2 {
+    inherit fetchurl stdenv;
+    static = true;
+    devicemapper = devicemapperStatic;
+  }));
+
   mdadm = import ../os-specific/linux/mdadm {
     inherit fetchurl stdenv groff;
   };
@@ -2823,7 +2838,7 @@ rec {
   };
 
   pidgin = import ../applications/networking/instant-messengers/pidgin {
-    inherit fetchurl stdenv pkgconfig perl perlXMLParser libxml2 openssl nss gtkspell GStreamer aspell gettext;
+    inherit fetchurl stdenv pkgconfig perl perlXMLParser libxml2 openssl nss gtkspell GStreamer aspell gettext ncurses;
     inherit (gtkLibs) gtk;
     inherit (gnome) startupnotification;
     inherit (xlibs) libXScrnSaver;