summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorFernando J Pando <fernando.pando@stelligent.com>2016-08-29 10:30:56 -0400
committerFrederik Rietdijk <fridh@fridh.nl>2016-09-01 10:56:29 +0200
commit3d09c34184fab15a748f5f7bfef4a98c9722d4bf (patch)
tree2f15280d6244d02cadb8800722a62e0863a8c721 /pkgs/top-level
parente6ced1cb1ff8de485b338d94d6b12ecb10bdab76 (diff)
downloadnixlib-3d09c34184fab15a748f5f7bfef4a98c9722d4bf.tar
nixlib-3d09c34184fab15a748f5f7bfef4a98c9722d4bf.tar.gz
nixlib-3d09c34184fab15a748f5f7bfef4a98c9722d4bf.tar.bz2
nixlib-3d09c34184fab15a748f5f7bfef4a98c9722d4bf.tar.lz
nixlib-3d09c34184fab15a748f5f7bfef4a98c9722d4bf.tar.xz
nixlib-3d09c34184fab15a748f5f7bfef4a98c9722d4bf.tar.zst
nixlib-3d09c34184fab15a748f5f7bfef4a98c9722d4bf.zip
pythonPackages.execnet: 1.1 -> 1.4.1
Tested on Linux
- python 2.7
- python 3.5
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix27
1 files changed, 19 insertions, 8 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 5cbc2682a335..686eede5202d 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -6229,20 +6229,31 @@ in modules // {
     };
   };
 
-
   execnet = buildPythonPackage rec {
-    name = "execnet-1.1";
-
+    name = "${pname}-${version}";
+    pname = "execnet";
+    version = "1.4.1";
     src = pkgs.fetchurl {
-      url = "mirror://pypi/e/execnet/${name}.zip";
-      sha256 = "fa1d8bd6b6d2282ff4df474b8ac687e1775bff4fc6462b219a5f89d5e9e6908c";
+      url = "mirror://pypi/e/${pname}/${name}.tar.gz";
+      sha256 = "1rpk1vyclhg911p3hql0m0nrpq7q7mysxnaaw6vs29cpa6kx8vgn";
     };
-
-    doCheck = !isPy3k;  # failures..
-
+    buildInputs = with self; [ pytest setuptools_scm ];
+    propagatedBuildInputs = with self; [ apipkg ];
+    # remove vbox tests
+    postPatch = ''
+      rm -v testing/test_termination.py
+      rm -v testing/test_channel.py
+      rm -v testing/test_xspec.py
+      rm -v testing/test_gateway.py
+    '';
+    checkPhase = ''
+      py.test testing
+    '';
     meta = {
       description = "Rapid multi-Python deployment";
       license = licenses.gpl2;
+      homepage = "http://codespeak.net/execnet";
+      maintainers = with maintainers; [ nand0p ];
     };
   };