summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorOlav <olavks@gmail.com>2015-02-17 03:53:05 +0000
committerOlav <olavks@gmail.com>2015-02-17 03:59:27 +0000
commit380bd3f48aa47d91f4a67c8cf8e17d1ade121c92 (patch)
tree4c43898eb1b32927175d7cf8349a17ea931c8ffa /pkgs/top-level
parenta52343ffe11c1b79130dee4626a2d84bc2d28aeb (diff)
downloadnixlib-380bd3f48aa47d91f4a67c8cf8e17d1ade121c92.tar
nixlib-380bd3f48aa47d91f4a67c8cf8e17d1ade121c92.tar.gz
nixlib-380bd3f48aa47d91f4a67c8cf8e17d1ade121c92.tar.bz2
nixlib-380bd3f48aa47d91f4a67c8cf8e17d1ade121c92.tar.lz
nixlib-380bd3f48aa47d91f4a67c8cf8e17d1ade121c92.tar.xz
nixlib-380bd3f48aa47d91f4a67c8cf8e17d1ade121c92.tar.zst
nixlib-380bd3f48aa47d91f4a67c8cf8e17d1ade121c92.zip
Numpy: Replace ATLAS and liblapack with openblas (that has blas and lapack).
Was previously with ATLAS [Automatically Tuned Linear Algebra Software].
This takes ages and has little to no performance benefit over openblas+lapack.
And if you need this performance, you should really built it against your own hardware.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 8b2721e28fdc..f34c49b873e3 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -6657,7 +6657,7 @@ let
     '';
 
     preBuild = ''
-      export BLAS=${pkgs.blas} LAPACK=${pkgs.liblapack}
+      export BLAS=${pkgs.openblas} LAPACK=${pkgs.openblas}
     '';
 
     setupPyBuildFlags = ["--fcompiler='gnu95'"];
@@ -6666,7 +6666,7 @@ let
     doCheck = false;
 
     buildInputs = with self; [ pkgs.gfortran ];
-    propagatedBuildInputs = with self; [ pkgs.liblapack pkgs.blas ];
+    propagatedBuildInputs = with self; [  pkgs.openblas ];
 
     meta = {
       description = "Scientific tools for Python";