summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorLancelot SIX <lsix@lancelotsix.com>2016-08-24 17:49:45 +0200
committerLancelot SIX <lsix@lancelotsix.com>2016-08-25 15:18:05 +0200
commit37ad0f8e6a9830acda2e4af417b7f8fd386a861d (patch)
treec3c80b5e6fb62dd0b1ab2fe7b54bcd8a7ae3fe72 /pkgs/top-level
parent674aa05abca627dc50a935daf3537175759cf3c6 (diff)
downloadnixlib-37ad0f8e6a9830acda2e4af417b7f8fd386a861d.tar
nixlib-37ad0f8e6a9830acda2e4af417b7f8fd386a861d.tar.gz
nixlib-37ad0f8e6a9830acda2e4af417b7f8fd386a861d.tar.bz2
nixlib-37ad0f8e6a9830acda2e4af417b7f8fd386a861d.tar.lz
nixlib-37ad0f8e6a9830acda2e4af417b7f8fd386a861d.tar.xz
nixlib-37ad0f8e6a9830acda2e4af417b7f8fd386a861d.tar.zst
nixlib-37ad0f8e6a9830acda2e4af417b7f8fd386a861d.zip
pythonPackages.django: always build with the GIS componnents
There is no reason for django derivation to contain invalid GIS
extensions. This makes sure that the gis componnents (which are always
installed) can function properly.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix18
1 files changed, 8 insertions, 10 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 011d59da6b7d..9056f38d81b1 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -8936,16 +8936,6 @@ in modules // {
 
   django = self.django_1_10;
 
-  django_gis = self.django.override rec {
-    patches = [
-      (pkgs.substituteAll {
-        src = ../development/python-modules/django/1.10-gis-libs.template.patch;
-        geos = pkgs.geos;
-        gdal = pkgs.gdal;
-      })
-    ];
-  };
-
   django_1_10 = buildPythonPackage rec {
     name = "Django-${version}";
     version = "1.10";
@@ -8956,6 +8946,14 @@ in modules // {
       sha256 = "01bh5yra6zyxcpqacahbwfbn0y4ivw07j2jsw3crvmjzivb6if26";
     };
 
+    patches = [
+      (pkgs.substituteAll {
+        src = ../development/python-modules/django/1.10-gis-libs.template.patch;
+        geos = pkgs.geos;
+        gdal = self.gdal;
+      })
+    ];
+
     # patch only $out/bin to avoid problems with starter templates (see #3134)
     postFixup = ''
       wrapPythonProgramsIn $out/bin "$out $pythonPath"