summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2012-05-24 21:23:23 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2012-05-24 21:23:23 +0000
commit3729f9ce5ea25fbbe33f63277ebafca1c62f4683 (patch)
tree43a0bbaa3b6d7f43088f95683d8666c437c47edc /pkgs/top-level
parent37fce10f9b26b826d5030906406639bcd9e77e45 (diff)
downloadnixlib-3729f9ce5ea25fbbe33f63277ebafca1c62f4683.tar
nixlib-3729f9ce5ea25fbbe33f63277ebafca1c62f4683.tar.gz
nixlib-3729f9ce5ea25fbbe33f63277ebafca1c62f4683.tar.bz2
nixlib-3729f9ce5ea25fbbe33f63277ebafca1c62f4683.tar.lz
nixlib-3729f9ce5ea25fbbe33f63277ebafca1c62f4683.tar.xz
nixlib-3729f9ce5ea25fbbe33f63277ebafca1c62f4683.tar.zst
nixlib-3729f9ce5ea25fbbe33f63277ebafca1c62f4683.zip
Trying to add a few bits of mingw-w64. To be tested.
svn path=/nixpkgs/trunk/; revision=34228
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 3e0b1aa3904d..c7a0fae055d0 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -1852,7 +1852,9 @@ let
 
   gccCrossStageStatic = let
       isMingw = (stdenv.cross.libc == "msvcrt");
-      libcCross1 = if isMingw then windows.mingw_headers1 else null;
+      isMingw64 = (stdenv.cross.libc == "msvcrt64");
+      libcCross1 = if isMingw then windows.mingw_headers1 else
+                   if isMingw64 then windows.mingw_w64_headers else null;
     in
       wrapGCCCross {
       gcc = forceBuildDrv (lib.addMetaAttrs { platforms = []; } (
@@ -6076,6 +6078,15 @@ let
       paths = [ w32api mingw_runtime ];
     };
 
+    mingw_w64 = callPackage ../os-specific/windows/mingw-w64 {
+      gccCross = gccCrossStageStatic;
+      binutilsCross = binutilsCross;
+    };
+
+    mingw_w64_headers = callPackage ../os-specific/windows/mingw-w64 {
+      onlyHeaders = true;
+    };
+
     pthreads = callPackage ../os-specific/windows/pthread-w32 {
       mingw_headers = mingw_headers2;
     };