summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2017-12-31 02:36:18 +0100
committerJörg Thalheim <joerg@thalheim.io>2017-12-31 02:38:09 +0100
commit2efe8b95c8e99e11a8118591b93b35640d906ccb (patch)
treee513f8fd9409baa9320198b4a85abd6e9cc02f4a /pkgs/top-level
parent409642e52906fd306cc490c9fb05536087cefa25 (diff)
downloadnixlib-2efe8b95c8e99e11a8118591b93b35640d906ccb.tar
nixlib-2efe8b95c8e99e11a8118591b93b35640d906ccb.tar.gz
nixlib-2efe8b95c8e99e11a8118591b93b35640d906ccb.tar.bz2
nixlib-2efe8b95c8e99e11a8118591b93b35640d906ccb.tar.lz
nixlib-2efe8b95c8e99e11a8118591b93b35640d906ccb.tar.xz
nixlib-2efe8b95c8e99e11a8118591b93b35640d906ccb.tar.zst
nixlib-2efe8b95c8e99e11a8118591b93b35640d906ccb.zip
python.pkgs.mygpoclient: 1.7 -> 1.8
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix30
1 files changed, 1 insertions, 29 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 33050de509b9..e10d79468bc1 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -11338,35 +11338,7 @@ in {
     };
   });
 
-  mygpoclient = buildPythonPackage rec {
-    name = "mygpoclient-${version}";
-    version = "1.7";
-
-    src = pkgs.fetchurl {
-      url = "https://thp.io/2010/mygpoclient/${name}.tar.gz";
-      sha256 = "6a0b7b1fe2b046875456e14eda3e42430e493bf2251a64481cf4fd1a1e21a80e";
-    };
-
-    buildInputs = with self; [ nose minimock ];
-
-    checkPhase = ''
-      nosetests
-    '';
-
-    disabled = isPy3k;
-
-    meta = {
-      description = "A gpodder.net client library";
-      longDescription = ''
-        The mygpoclient library allows developers to utilize a Pythonic interface
-        to the gpodder.net web services.
-      '';
-      homepage = https://thp.io/2010/mygpoclient/;
-      license = with licenses; [ gpl3 ];
-      platforms = with platforms; linux ++ darwin;
-      maintainers = with maintainers; [ skeidel ];
-    };
-  };
+  mygpoclient = callPackage ../development/python-modules/mygpoclient { };
 
   mwclient = buildPythonPackage rec {
     version = "0.8.3";