summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorJohn Ericson <Ericson2314@Yahoo.com>2017-04-24 20:12:43 -0400
committerJohn Ericson <Ericson2314@Yahoo.com>2017-05-17 11:14:59 -0400
commit296753f0947427d5753be68ae10363ac1b8b4cdc (patch)
tree599ad9bb98506efbb21982310bee9d062a7b26a1 /pkgs/top-level
parent9c90ff7e7df9ceadc7335bb43cc67ba92e171d53 (diff)
downloadnixlib-296753f0947427d5753be68ae10363ac1b8b4cdc.tar
nixlib-296753f0947427d5753be68ae10363ac1b8b4cdc.tar.gz
nixlib-296753f0947427d5753be68ae10363ac1b8b4cdc.tar.bz2
nixlib-296753f0947427d5753be68ae10363ac1b8b4cdc.tar.lz
nixlib-296753f0947427d5753be68ae10363ac1b8b4cdc.tar.xz
nixlib-296753f0947427d5753be68ae10363ac1b8b4cdc.tar.zst
nixlib-296753f0947427d5753be68ae10363ac1b8b4cdc.zip
lib: Consolidate tests into one meta job
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/make-tarball.nix11
-rw-r--r--pkgs/top-level/release.nix6
2 files changed, 12 insertions, 5 deletions
diff --git a/pkgs/top-level/make-tarball.nix b/pkgs/top-level/make-tarball.nix
index a69e7019c874..c7e5f21910bb 100644
--- a/pkgs/top-level/make-tarball.nix
+++ b/pkgs/top-level/make-tarball.nix
@@ -57,8 +57,15 @@ releaseTools.sourceTarball rec {
     fi
 
     # Run the regression tests in `lib'.
-    res="$(nix-instantiate --eval --strict --show-trace lib/tests.nix)"
-    if test "$res" != "[ ]"; then
+    if
+        # `set -e` doesn't work inside here, so need to && instead :(
+        res="$(nix-instantiate --eval --strict lib/tests/misc.nix)" \
+        && [[ "$res" == "[ ]" ]] \
+        && res="$(nix-instantiate --eval --strict lib/tests/systems.nix)" \
+        && [[ "$res" == "[ ]" ]]
+    then
+        true
+    else
         echo "regression tests for lib failed, got: $res"
         exit 1
     fi
diff --git a/pkgs/top-level/release.nix b/pkgs/top-level/release.nix
index cf4d54fe0496..3931a3fe73ed 100644
--- a/pkgs/top-level/release.nix
+++ b/pkgs/top-level/release.nix
@@ -28,7 +28,7 @@ let
       metrics = import ./metrics.nix { inherit pkgs nixpkgs; };
 
       manual = import ../../doc;
-      lib-tests = import ../../lib/tests/release.nix { inherit nixpkgs supportedSystems scrubJobs; };
+      lib-tests = import ../../lib/tests/release.nix { inherit pkgs; };
 
       darwin-tested = pkgs.releaseTools.aggregate
         { name = "nixpkgs-darwin-${jobs.tarball.version}";
@@ -52,6 +52,7 @@ let
             [ jobs.tarball
               jobs.metrics
               jobs.manual
+              jobs.lib-tests
               jobs.stdenv.x86_64-linux
               jobs.stdenv.i686-linux
               jobs.stdenv.x86_64-darwin
@@ -78,8 +79,7 @@ let
               jobs.git.x86_64-darwin
               jobs.mysql.x86_64-darwin
               jobs.vim.x86_64-darwin
-            ] ++ lib.collect lib.isDerivation jobs.stdenvBootstrapTools
-              ++ lib.collect lib.isDerivation jobs.lib-tests;
+            ] ++ lib.collect lib.isDerivation jobs.stdenvBootstrapTools;
         };
     } // (lib.optionalAttrs (builtins.elem "i686-linux" supportedSystems) {
       stdenvBootstrapTools.i686-linux =