summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorJohn Ericson <Ericson2314@Yahoo.com>2017-02-17 00:36:10 -0500
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-02-27 14:15:39 -0500
commit2482e2858e7e2d5e91f506932f3774288ca6120d (patch)
tree3619ff9d81826a55baa3d4b10ab8a4f1c96d3abe /pkgs/top-level
parentdfc5d7835d6e248d3cc83430da941277ae5cabaa (diff)
downloadnixlib-2482e2858e7e2d5e91f506932f3774288ca6120d.tar
nixlib-2482e2858e7e2d5e91f506932f3774288ca6120d.tar.gz
nixlib-2482e2858e7e2d5e91f506932f3774288ca6120d.tar.bz2
nixlib-2482e2858e7e2d5e91f506932f3774288ca6120d.tar.lz
nixlib-2482e2858e7e2d5e91f506932f3774288ca6120d.tar.xz
nixlib-2482e2858e7e2d5e91f506932f3774288ca6120d.tar.zst
nixlib-2482e2858e7e2d5e91f506932f3774288ca6120d.zip
prebuilt android tools: Init using SDK
Expose as an option for the cross stdenv.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix5
-rw-r--r--pkgs/top-level/release-cross.nix7
2 files changed, 10 insertions, 2 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 24908b4863b7..68cf3e6bb15e 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -8326,6 +8326,10 @@ with pkgs;
 
   libopcodes = callPackage ../development/libraries/libopcodes { };
 
+  # TODO(@Ericson2314): Build bionic libc from source
+  bionic = assert hostPlatform.useAndroidPrebuilt;
+    androidenv.androidndkPkgs.libraries;
+
   bobcat = callPackage ../development/libraries/bobcat { };
 
   boehmgc = callPackage ../development/libraries/boehm-gc { };
@@ -8862,6 +8866,7 @@ with pkgs;
     # libc is hackily often used from the previous stage. This `or`
     # hack fixes the hack, *sigh*.
     /**/ if name == "glibc" then targetPackages.glibcCross or glibcCross
+    else if name == "bionic" then targetPackages.bionic
     else if name == "uclibc" then uclibcCross
     else if name == "musl" then targetPackages.muslCross or muslCross
     else if name == "msvcrt" then targetPackages.windows.mingw_w64 or windows.mingw_w64
diff --git a/pkgs/top-level/release-cross.nix b/pkgs/top-level/release-cross.nix
index be6dd89bf7dd..ef99dbd619e4 100644
--- a/pkgs/top-level/release-cross.nix
+++ b/pkgs/top-level/release-cross.nix
@@ -93,6 +93,7 @@ in
     mapTestEqual = lib.mapAttrsRecursive testEqual;
 
   in mapTestEqual {
+    androidndk = nativePlatforms;
     boehmgc = nativePlatforms;
     libffi = nativePlatforms;
     libiconv = nativePlatforms;
@@ -125,12 +126,14 @@ in
   rpi = mapTestOnCross lib.systems.examples.raspberryPi rpiCommon;
   rpi-musl = mapTestOnCross lib.systems.examples.muslpi rpiCommon;
 
-  /* Linux on Aarch64 (TODO make android for real)  */
-  android = mapTestOnCross lib.systems.examples.aarch64-multiplatform linuxCommon;
   aarch64-musl = mapTestOnCross lib.systems.examples.aarch64-multiplatform-musl linuxCommon;
 
   x86_64-musl = mapTestOnCross lib.systems.examples.musl64 linuxCommon;
 
+  /* Linux on Aarch64 */
+  android64 = mapTestOnCross lib.systems.examples.aarch64-android-prebuilt (linuxCommon // {
+  });
+
   /* Cross-built bootstrap tools for every supported platform */
   bootstrapTools = let
     tools = import ../stdenv/linux/make-bootstrap-tools-cross.nix { system = "x86_64-linux"; };