summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2015-03-26 16:17:31 +0100
committerPeter Simons <simons@cryp.to>2015-03-26 16:17:31 +0100
commit230182f61b001ff04f418c2e8ef9561235f6e002 (patch)
tree632baee46b0968a9b4b7306454ecddbba00ec028 /pkgs/top-level
parent636b25af67e573a625ae5cc5f0d203d99cbfb2f9 (diff)
downloadnixlib-230182f61b001ff04f418c2e8ef9561235f6e002.tar
nixlib-230182f61b001ff04f418c2e8ef9561235f6e002.tar.gz
nixlib-230182f61b001ff04f418c2e8ef9561235f6e002.tar.bz2
nixlib-230182f61b001ff04f418c2e8ef9561235f6e002.tar.lz
nixlib-230182f61b001ff04f418c2e8ef9561235f6e002.tar.xz
nixlib-230182f61b001ff04f418c2e8ef9561235f6e002.tar.zst
nixlib-230182f61b001ff04f418c2e8ef9561235f6e002.zip
pythonPackages.subunit: revert "rewrite to use buildPythonPackage"
This reverts commit e42547d8e9f6cf04a6969c7b486b72da3e17cb90. The change
broke samba and dependent packages.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index a79d9d296cc1..8281c25e4ea4 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -10866,17 +10866,21 @@ let
   });
 
 
-  subunit = buildPythonPackage rec {
+  subunit = stdenv.mkDerivation rec {
     name = "subunit-${version}";
-    version = "1.1.0";
+    version = "1.0.0";
 
     src = pkgs.fetchurl {
-      url = "https://pypi.python.org/packages/source/p/python-subunit/python-subunit-${version}.tar.gz";
-      sha256 = "125zh5i1f21ficn8ix5q33jk87j2pfmzbw6jq5l8v0hhjrp619yr";
+      url = "https://launchpad.net/subunit/trunk/${version}/+download/${name}.tar.gz";
+      sha256 = "1fnhrrwww90746an2nz2kn9qdf9pklmaf5lm22gssl6648f2rp2m";
     };
 
+    buildInputs = (with pkgs; [ pkgconfig check cppunit perl ]) ++ [ self.wrapPython ];
+
     propagatedBuildInputs = with self; [ testtools testscenarios ];
 
+    postFixup = "wrapPythonPrograms";
+
     meta = {
       description = "A streaming protocol for test results";
       homepage = https://launchpad.net/subunit;