summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorJaakko Luttinen <jaakko.luttinen@iki.fi>2017-09-03 20:54:32 +0300
committerFrederik Rietdijk <freddyrietdijk@fridh.nl>2017-09-04 11:09:32 +0200
commit145fa7ac1f355e4d8f71ccd7e7ef4a059519f70a (patch)
tree1925e329c8bee9c918c6138bdd3eca81c48ddfb9 /pkgs/top-level
parent81d2549e8b49fdf3f6e826dc96ad602d822b2714 (diff)
downloadnixlib-145fa7ac1f355e4d8f71ccd7e7ef4a059519f70a.tar
nixlib-145fa7ac1f355e4d8f71ccd7e7ef4a059519f70a.tar.gz
nixlib-145fa7ac1f355e4d8f71ccd7e7ef4a059519f70a.tar.bz2
nixlib-145fa7ac1f355e4d8f71ccd7e7ef4a059519f70a.tar.lz
nixlib-145fa7ac1f355e4d8f71ccd7e7ef4a059519f70a.tar.xz
nixlib-145fa7ac1f355e4d8f71ccd7e7ef4a059519f70a.tar.zst
nixlib-145fa7ac1f355e4d8f71ccd7e7ef4a059519f70a.zip
pythonPackages.attrs: 16.2.0 -> 17.2.0
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix24
1 files changed, 1 insertions, 23 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 1ba770ac0315..a23c668d07e7 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -647,29 +647,7 @@ in {
     };
   });
 
-  attrs = buildPythonPackage (rec {
-    name = "attrs-${version}";
-    version = "16.2.0";
-    src = pkgs.fetchurl {
-      url = "mirror://pypi/a/attrs/${name}.tar.gz";
-      sha256 = "136f2ec0f94ec77ff2990830feee965d608cab1e8922370e3abdded383d52001";
-    };
-
-    # macOS needs clang for testing
-    buildInputs = with self; [ pytest hypothesis zope_interface
-    pympler coverage ]
-     ++ optionals (stdenv.isDarwin) [ pkgs.clang ];
-
-    checkPhase = ''
-      py.test
-    '';
-
-    meta = {
-      description = "Python attributes without boilerplate";
-      homepage = https://github.com/hynek/attrs;
-      license = licenses.mit;
-    };
-   });
+  attrs = callPackage ../development/python-modules/attrs { };
 
   audioread = callPackage ../development/python-modules/audioread { };