summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2018-08-01 16:09:55 +0200
committerxeji <36407913+xeji@users.noreply.github.com>2018-08-01 16:09:55 +0200
commit134c5cc8dbf317584b2e53273e4bacd59e20b9f7 (patch)
tree4c05759b191a6dd988825d178c38a062cc3bd24d /pkgs/top-level
parent2b75a7266c41d1b22f6296ac31fb3dc8d42eb33a (diff)
downloadnixlib-134c5cc8dbf317584b2e53273e4bacd59e20b9f7.tar
nixlib-134c5cc8dbf317584b2e53273e4bacd59e20b9f7.tar.gz
nixlib-134c5cc8dbf317584b2e53273e4bacd59e20b9f7.tar.bz2
nixlib-134c5cc8dbf317584b2e53273e4bacd59e20b9f7.tar.lz
nixlib-134c5cc8dbf317584b2e53273e4bacd59e20b9f7.tar.xz
nixlib-134c5cc8dbf317584b2e53273e4bacd59e20b9f7.tar.zst
nixlib-134c5cc8dbf317584b2e53273e4bacd59e20b9f7.zip
termite: factor wrapper out into its own file (#43691)
Until now it's impossible to override the attrs of the actual build
instruction for the `termite` package like this:

```
termite.overrideAttrs (_: {
  # ...
})
```

This issue occurs since the `termite/default.nix` expressions returns
the `symlinkJoin` expression when I override termite (e.g. to provide a
config file).

I recently patched termite and wanted to apply this patch to my local
termite installation in my system config which is impossible this, so
splitting the wrapper and the build instruction into their own files
makes this way easier to maintian.
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 7d2694238d8a..1623c1262d66 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -18549,10 +18549,12 @@ with pkgs;
     vte = gnome3.vte;
   };
 
-  termite = callPackage ../applications/misc/termite {
+  termite-unwrapped = callPackage ../applications/misc/termite {
     vte = gnome3.vte-ng;
   };
 
+  termite = callPackage ../applications/misc/termite/wrapper.nix { termite = termite-unwrapped; };
+
   termtosvg = callPackage ../tools/misc/termtosvg { };
 
   tesseract = callPackage ../applications/graphics/tesseract { };