summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2018-07-19 01:19:45 +0200
committerMaximilian Bosch <maximilian@mbosch.me>2018-07-19 17:31:40 +0200
commit10439f798e86a69831bb334fa72cb869292cd289 (patch)
tree7408299697b3ae29f42f51ea717a71ca4eb2a21f /pkgs/top-level
parenta7e5927b4739c6e6427fc993f077cd3eb5433db7 (diff)
downloadnixlib-10439f798e86a69831bb334fa72cb869292cd289.tar
nixlib-10439f798e86a69831bb334fa72cb869292cd289.tar.gz
nixlib-10439f798e86a69831bb334fa72cb869292cd289.tar.bz2
nixlib-10439f798e86a69831bb334fa72cb869292cd289.tar.lz
nixlib-10439f798e86a69831bb334fa72cb869292cd289.tar.xz
nixlib-10439f798e86a69831bb334fa72cb869292cd289.tar.zst
nixlib-10439f798e86a69831bb334fa72cb869292cd289.zip
python3Packages.simpleldap: remove
Fairly outdated and incompatible with Python 3, see the following links
for further reference:

* https://github.com/gdub/python-simpleldap/blob/0.8/setup.py#L12-L14
* https://github.com/NixOS/nixpkgs/pull/43782#issuecomment-406186881
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix24
1 files changed, 0 insertions, 24 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index 450a21f34631..6798778f3a14 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -12638,30 +12638,6 @@ in {
 
   simplejson = callPackage ../development/python-modules/simplejson { };
 
-  simpleldap = buildPythonPackage rec {
-    version = "0.8";
-    name = "simpleldap-${version}";
-
-    propagatedBuildInputs = with self; [ ldap ];
-    buildInputs = with self; [ pep8 pytest tox ];
-
-    src = pkgs.fetchurl {
-      url = "mirror://pypi/s/simpleldap/simpleldap-${version}.tar.gz";
-      sha256 = "a5916680a7fe1b2c5d74dc76351be2941d03b7b94a50d8520280e3f588a84e61";
-    };
-
-    meta = {
-      description = "A module that makes simple LDAP usage simple";
-      longDescription = ''
-        A small wrapper around the python-ldap library that provides a more
-        Pythonic interface for LDAP server connections, LDAP objects, and the
-        common get and search operations.
-      '';
-      license = licenses.mit;
-      maintainers = with maintainers; [ layus ];
-    };
-  };
-
   simpleparse = buildPythonPackage rec {
     version = "2.1.1";
     name = "simpleparse-${version}";