summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2017-05-26 03:47:08 +0300
committerNikolay Amiantov <ab@fmap.me>2017-06-04 00:38:30 +0300
commit0dc54737306051cf8649394b96f5e9513616fa8b (patch)
tree5b276379076157702231060d3a0d49d14c294e77 /pkgs/top-level
parent62653064a0dee52810bc6c5b1d68dc55368d7115 (diff)
downloadnixlib-0dc54737306051cf8649394b96f5e9513616fa8b.tar
nixlib-0dc54737306051cf8649394b96f5e9513616fa8b.tar.gz
nixlib-0dc54737306051cf8649394b96f5e9513616fa8b.tar.bz2
nixlib-0dc54737306051cf8649394b96f5e9513616fa8b.tar.lz
nixlib-0dc54737306051cf8649394b96f5e9513616fa8b.tar.xz
nixlib-0dc54737306051cf8649394b96f5e9513616fa8b.tar.zst
nixlib-0dc54737306051cf8649394b96f5e9513616fa8b.zip
gcc7: init at 7.1.0
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index dcf644ac8ddc..ad0cfb1bad52 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -5261,6 +5261,21 @@ with pkgs;
     isl = if !stdenv.isDarwin then isl_0_14 else null;
   }));
 
+  gcc7 = lowPrio (wrapCC (callPackage ../development/compilers/gcc/7 {
+    inherit noSysDirs;
+
+    # PGO seems to speed up compilation by gcc by ~10%, see #445 discussion
+    profiledCompiler = with stdenv; (!isDarwin && (isi686 || isx86_64));
+
+    # When building `gcc.crossDrv' (a "Canadian cross", with host == target
+    # and host != build), `cross' must be null but the cross-libc must still
+    # be passed.
+    cross = null;
+    libcCross = if targetPlatform != buildPlatform then libcCross else null;
+
+    isl = if !stdenv.isDarwin then isl_0_17 else null;
+  }));
+
   gcc-snapshot = lowPrio (wrapCC (callPackage ../development/compilers/gcc/snapshot {
     inherit noSysDirs;