summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-03-04 20:42:51 +0000
committerGitHub <noreply@github.com>2018-03-04 20:42:51 +0000
commit0be67e24b783451f8773bd59aac0bc35e96afddc (patch)
tree744ae0228537ba1316fb05d80223dfbede1896b5 /pkgs/top-level
parenteca1f71f32c984d242c25dcd46e3afa65b23644d (diff)
parentcafcd6e9f4442011da2dc35f6be5cbbd0868455d (diff)
downloadnixlib-0be67e24b783451f8773bd59aac0bc35e96afddc.tar
nixlib-0be67e24b783451f8773bd59aac0bc35e96afddc.tar.gz
nixlib-0be67e24b783451f8773bd59aac0bc35e96afddc.tar.bz2
nixlib-0be67e24b783451f8773bd59aac0bc35e96afddc.tar.lz
nixlib-0be67e24b783451f8773bd59aac0bc35e96afddc.tar.xz
nixlib-0be67e24b783451f8773bd59aac0bc35e96afddc.tar.zst
nixlib-0be67e24b783451f8773bd59aac0bc35e96afddc.zip
Merge pull request #35438 from boronine/bibtex-darwin-fix
perlPackages.TextBibTeX: fix dylib path for Darwin
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/perl-packages.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/pkgs/top-level/perl-packages.nix b/pkgs/top-level/perl-packages.nix
index 815bf73210f6..1a341bef60d0 100644
--- a/pkgs/top-level/perl-packages.nix
+++ b/pkgs/top-level/perl-packages.nix
@@ -14722,6 +14722,16 @@ let self = _self // overrides; _self = with self; {
       sha256 = "0dig1zlglm8rwm8fhnz087lx6gixj9jx10kxn1fx3swdkfblhsmf";
     };
     perlPreHook = "export LD=$CC";
+    perlPostHook = stdenv.lib.optionalString stdenv.isDarwin ''
+      oldPath="$(pwd)/btparse/src/libbtparse.dylib"
+      newPath="$out/lib/libbtparse.dylib"
+
+      install_name_tool -id "$newPath" "$newPath"
+      install_name_tool -change "$oldPath" "$newPath" "$out/bin/biblex"
+      install_name_tool -change "$oldPath" "$newPath" "$out/bin/bibparse"
+      install_name_tool -change "$oldPath" "$newPath" "$out/bin/dumpnames"
+      install_name_tool -change "$oldPath" "$newPath" "$out/lib/perl5/site_perl/5.24.3/darwin-2level/auto/Text/BibTeX/BibTeX.bundle"
+    '';
     meta = {
       description = "Interface to read and parse BibTeX files";
       license = with stdenv.lib.licenses; [ artistic1 gpl1Plus ];