summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-12-16 23:20:45 -0800
committerGitHub <noreply@github.com>2017-12-16 23:20:45 -0800
commit0643952fa56cd00b708cf37d65ba531b72c6e95d (patch)
tree6dee13f33d9ec8ffcc5b87911d72405b4e8c7f8b /pkgs/top-level
parent28541e2a3f6783ea6fd66256707c0dfdf969d8a1 (diff)
parent6b2a80a1fc2ab336d8f97cef40f7e3d740d4c56b (diff)
downloadnixlib-0643952fa56cd00b708cf37d65ba531b72c6e95d.tar
nixlib-0643952fa56cd00b708cf37d65ba531b72c6e95d.tar.gz
nixlib-0643952fa56cd00b708cf37d65ba531b72c6e95d.tar.bz2
nixlib-0643952fa56cd00b708cf37d65ba531b72c6e95d.tar.lz
nixlib-0643952fa56cd00b708cf37d65ba531b72c6e95d.tar.xz
nixlib-0643952fa56cd00b708cf37d65ba531b72c6e95d.tar.zst
nixlib-0643952fa56cd00b708cf37d65ba531b72c6e95d.zip
Merge pull request #32375 from volth/oracle-jdk-remove-redundand-asserts
oraclejdk: remove redundant asserts
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/all-packages.nix9
1 files changed, 0 insertions, 9 deletions
diff --git a/pkgs/top-level/all-packages.nix b/pkgs/top-level/all-packages.nix
index 5d3ea9a5588f..140e562b179d 100644
--- a/pkgs/top-level/all-packages.nix
+++ b/pkgs/top-level/all-packages.nix
@@ -6090,26 +6090,17 @@ with pkgs;
 
   jre8Plugin = lowPrio (pkgs.oraclejdk8distro false true);
 
-  supportsJDK =
-    system == "i686-linux" ||
-    system == "x86_64-linux" ||
-    system == "armv7l-linux" ||
-    system == "aarch64-linux";
-
   jdkdistro = oraclejdk8distro;
 
   oraclejdk8distro = installjdk: pluginSupport:
-    assert supportsJDK;
     (if pluginSupport then appendToName "with-plugin" else x: x)
       (callPackage ../development/compilers/oraclejdk/jdk8cpu-linux.nix { inherit installjdk pluginSupport; });
 
   oraclejdk8psu_distro = installjdk: pluginSupport:
-    assert supportsJDK;
     (if pluginSupport then appendToName "with-plugin" else x: x)
       (callPackage ../development/compilers/oraclejdk/jdk8psu-linux.nix { inherit installjdk pluginSupport; });
 
   oraclejdk9distro = packageType: pluginSupport:
-    assert supportsJDK;
     (if pluginSupport then appendToName "with-plugin" else x: x)
       (callPackage ../development/compilers/oraclejdk/jdk9-linux.nix { inherit packageType pluginSupport; });