summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-06-09 12:29:44 -0400
committerGitHub <noreply@github.com>2018-06-09 12:29:44 -0400
commitf523dc90257d14ae795f0807d05125364ae228ce (patch)
treebfbc41620fbfc681a9cead658444c03a4007056b /pkgs/tools
parenta448357dc62b26c95c3df84a156656e54aaf58b1 (diff)
parentc256347ceea6c0434fd755e8c8fb5f6a7df620d6 (diff)
downloadnixlib-f523dc90257d14ae795f0807d05125364ae228ce.tar
nixlib-f523dc90257d14ae795f0807d05125364ae228ce.tar.gz
nixlib-f523dc90257d14ae795f0807d05125364ae228ce.tar.bz2
nixlib-f523dc90257d14ae795f0807d05125364ae228ce.tar.lz
nixlib-f523dc90257d14ae795f0807d05125364ae228ce.tar.xz
nixlib-f523dc90257d14ae795f0807d05125364ae228ce.tar.zst
nixlib-f523dc90257d14ae795f0807d05125364ae228ce.zip
Merge pull request #41759 from bhipple/fix/pcsclite
pcsclite: fix URL for debian move to gitlab
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/aria2/default.nix4
-rw-r--r--pkgs/tools/security/pcsclite/default.nix15
2 files changed, 10 insertions, 9 deletions
diff --git a/pkgs/tools/networking/aria2/default.nix b/pkgs/tools/networking/aria2/default.nix
index 29186906d27b..87725f51a7fb 100644
--- a/pkgs/tools/networking/aria2/default.nix
+++ b/pkgs/tools/networking/aria2/default.nix
@@ -5,13 +5,13 @@
 
 stdenv.mkDerivation rec {
   name = "aria2-${version}";
-  version = "1.33.1";
+  version = "1.34.0";
 
   src = fetchFromGitHub {
     owner = "aria2";
     repo = "aria2";
     rev = "release-${version}";
-    sha256 = "0ai84ijgsvnixwhxkj8if2mj9hcg2a41w81vy8bdvi89h3bmq9zf";
+    sha256 = "0hwqnjyszasr6049vr5mn48slb48v5kw39cbpbxa68ggmhj9bw6m";
   };
 
   nativeBuildInputs = [ pkgconfig autoreconfHook ];
diff --git a/pkgs/tools/security/pcsclite/default.nix b/pkgs/tools/security/pcsclite/default.nix
index 589316b1d1c5..3904a1eaca35 100644
--- a/pkgs/tools/security/pcsclite/default.nix
+++ b/pkgs/tools/security/pcsclite/default.nix
@@ -1,15 +1,16 @@
-{ stdenv, fetchurl, pkgconfig, udev, dbus_libs, perl, python2
+{ stdenv, fetchFromGitLab, pkgconfig, udev, dbus_libs, perl, python2
 , IOKit ? null }:
 
 stdenv.mkDerivation rec {
   name = "pcsclite-${version}";
   version = "1.8.23";
 
-  src = fetchurl {
-    # This URL changes in unpredictable ways, so it is not sensible
-    # to put a version variable in there.
-    url = "https://alioth.debian.org/frs/download.php/file/4235/pcsc-lite-1.8.23.tar.bz2";
-    sha256 = "1jc9ws5ra6v3plwraqixin0w0wfxj64drahrbkyrrwzghqjjc9ss";
+  src = fetchFromGitLab {
+    domain = "salsa.debian.org";
+    owner = "debian";
+    repo = "pcsc-lite";
+    rev = "upstream%2F${version}";
+    sha256 = "09b7a79hjkgiyvhyvwf8gpxaf8b7wd0342hx6zrpd269hhfbjvwy";
   };
 
   patches = [ ./no-dropdir-literals.patch ];
@@ -36,7 +37,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     description = "Middleware to access a smart card using SCard API (PC/SC)";
-    homepage = http://pcsclite.alioth.debian.org/;
+    homepage = https://salsa.debian.org/debian/pcsc-lite;
     license = licenses.bsd3;
     maintainers = with maintainers; [ viric wkennington ];
     platforms = with platforms; unix;