summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@mailbox.org>2017-07-31 19:58:38 -0500
committerThomas Tuegel <ttuegel@mailbox.org>2017-07-31 19:58:38 -0500
commitf3a54b014ce9cc3bbf2a65ab88291cbc3e3701b6 (patch)
tree43351d26f0d491eda25a9706f070782aa3a35e09 /pkgs/tools
parent9b10fcce2f1e23aefcb129179f8308153ee5a4a0 (diff)
downloadnixlib-f3a54b014ce9cc3bbf2a65ab88291cbc3e3701b6.tar
nixlib-f3a54b014ce9cc3bbf2a65ab88291cbc3e3701b6.tar.gz
nixlib-f3a54b014ce9cc3bbf2a65ab88291cbc3e3701b6.tar.bz2
nixlib-f3a54b014ce9cc3bbf2a65ab88291cbc3e3701b6.tar.lz
nixlib-f3a54b014ce9cc3bbf2a65ab88291cbc3e3701b6.tar.xz
nixlib-f3a54b014ce9cc3bbf2a65ab88291cbc3e3701b6.tar.zst
nixlib-f3a54b014ce9cc3bbf2a65ab88291cbc3e3701b6.zip
otfcc: init at 0.8.6
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/otfcc/default.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/pkgs/tools/misc/otfcc/default.nix b/pkgs/tools/misc/otfcc/default.nix
new file mode 100644
index 000000000000..ac64978bdd1a
--- /dev/null
+++ b/pkgs/tools/misc/otfcc/default.nix
@@ -0,0 +1,40 @@
+{ stdenv, fetchurl, premake5 }:
+
+let version = "0.8.6"; in
+
+let
+  arch =
+    {
+      "i686-linux" = "x86";
+      "x86_64-linux" = "x64";
+    }.${stdenv.system} or (throw "platform ${stdenv.system} is not supported");
+in
+
+stdenv.mkDerivation {
+  name = "otfcc-${version}";
+  src = fetchurl {
+    url = "https://github.com/caryll/otfcc/archive/v${version}.tar.gz";
+    sha256 = "0kap52bzrn21fmph8j2pc71f80f38ak1p2fcczzmrh0hb1r9c8dd";
+  };
+  nativeBuildInputs = [ premake5 ];
+  configurePhase = ''
+    runHook preConfigure
+    premake5 gmake
+    runHook postConfigure
+  '';
+  buildPhase = ''
+    runHook preBuild
+    cd build/gmake
+    make config=release_${arch}
+    cd ../..
+    runHook postBuild
+  '';
+  installPhase = ''
+    runHook preInstall
+    install -d "$out/lib"
+    install "bin/release-${arch}/"lib* "$out/lib"
+    install -d "$out/bin"
+    install "bin/release-${arch}/"otfcc* "$out/bin"
+    runHook postInstall
+  '';
+}